[SOLVED] Server Console Commands


I need to be able to allow users/moderators etc to be able to use the server commands, like they would in the traditional .jar window that pops up when you have a server running in windows. Preferably through the webconsole, as the mods aren’t well versed in linux command line. But if it has to be through cli that is fine as well. I read about a screen command that you can use, but I am not sure how to use it in regards to minecraft.

They got used to using these commands to manage permissions for Essentials and other addons that we are using on this server.

If we can’t get this, I think they will ask me to move back to a traditional minecraft server instead of mineOS.

Thanks for your help.

To clarify your talking about in game commands right? Such as ‘/gamemode 0’

Log into the web UI for MineOS. Click on the server that you have running on the dashboard. Then click on the left column logs/latest.log and then enter ‘/gamemode 0’ and any other commands mods add.

Thanks for the reply.

When I type that I see unknown command, type /help for help.
If I type /help it shows a bunch of commands, and even typing any of them show unknown command.

I’m I am able to run server commands as suggested above in MineOS. Make sure your typing / before all of your commands.

What kind of server are you running vanilla, forge…?

1 Like

It’s a spigot/bukkit server, that I used the import tool to make. It’s using an older version of spigot at the moment.

I am using the mineos-node_tkl-x64, version that was listed on the homepage, and just noticed the wiki says there is a newer version available.

Follow these instructions on how to update the Web UI and you should be good!

I’ve updated the webUI and it still isn’t working on the server I’ve created. I did a test however, logged into the webUI as MC, instead of root as I was previously logging in as. I created a server and I can use all of the console commands.

I can’t do simple commands like gamemode 0 on our old server. It’s some issue with the addons at this point I think

Thanks for your help.

There is a plugin that can do what you’re trying to do…it’s called RemoteBukkit available from BukkitDev

Download the plugin from here and install it the same way you would another plugin, then download the GUI/client version from here, use that to remotely access the server console.

But of course, there’s more to it…you’ll need to assign a specific port to be used by RemoteBukkit by modifying it’s config.yml, as well as creating user accounts in it’s config.yml;

Once you’ve configured the plugin’s port and user accounts, you’ll still need to open up the port you chose for the plugin by executing this in a Linux terminal/CLI:

iptables -A INPUT -p tcp -m tcp --dport 25566 -j ACCEPT

Now obviously before execute this, you should change “25566” to the port you chose (unless you happened to choose that port)…however this won’t stick after a reboot so you’ll also need to save it using this command so that it does re-open upon a reboot:

iptables-save > /etc/iptables-rules

If you encounter any errors with the commands, then you should try running with root (root account, sudo, or su).

1 Like

Why don’t you just /op the users/mods so they can enter these commands right in game?

More often than not if Admins run a medium to large server from council instead of in game.

for anyone that searches this just now like me I tried putting in commands without the slash after updating the webui and it worked fine for example:

op (username)

1 Like