[SOLVED] Putty or WinSCP wont connect with root

I am able to get into putty as MC then su over to root
I cant just goto root, I get Access denied

I can log into MC with WinSCP
i CANT log into Root with WinSCP, i get Access denied

I was able to create the profiles, create MC in Web UI
I was able to change to MC in web UI and create the server and start them up.

I can only think that i messed up my root password, but I can do the SU in putty and the webshell.
I just cant go directly to root with the password.

Thanks for the help,
Brian L


Forgive the short post, I’m on my phone.

No worries, but I am unable to do that as i get “error writing /etc/ssh/sshd_config: permission denied”
Im trying to put an archive from my old server onto the new one using WinSCP.
I am unable to move it using MC as it says access denied.

Thanks for the quick reply even if it was short.
Short and to the point is fine with me.
But I swear I looked up and down in the wiki for something like this.
Must have gotten the wrong keywords when typing it in.

Brian L

UPDATE: I went into webshell and was able to make the change, but not through putty.
Nope that was done as root and not MC and saved.
Tried it again with MC, wont let me save the files “access denied”
Working on it right now.

Got it done, with a little more digging got it to use mc so i could copy the file over, then root to the import folder.
When I loaded it, some of the chucks were overwritten, but most of the world came over.

Have you changed the root password?

I found simply doing iirc sudo passwd root
Then giving a new password has allowed root access.

I restarted the server for the like 20th time, and now I can root directly into with WinSCP and Putty.
I didnt do what you mentioned ElPres, but thanks for the heads up in case someone else has the problem.

This appears to be one of the new security features.
When installing from the .iso it asks you if you want to update security automatically. If you say “skip”, you can SSH directly into root. If you say “yes”, it works as you described, must log in as MC, then SU to root.
I’m guessing it was seen as a security gap.

1 Like

Awesome to know that for furture installs of MineOS.
You are correct because I remember saying yes as I didnt want to mess with having to do updates later.

Brian L