[Solved] PLAYERS ONLINE Shows 0 All the time


#1

This was working.

We rebooted the host, and now it show 0 players, even tho we have several player on the server.

Any thoughts?

git commit: 110c591 is the version.


#2

No code changes involving that sort of thing at all anytime recently. Did anything else change, such as the server version (updated?) or mods, etc.?

What kind of server, what version, and are you using enable-query in your server.properties?


#3

Server is just like we installed it, no changes ,the MC server is vanilla no mods running 1.8.9 , and we do have enable-query checked, as it was working for a day …


#4

Well i have widdle it down to a local network issue some where, if you try and query the server local or from another pc on the same network you get no response, i have double checked the server.properties to make sure that enable-query is set to true.

if you query the server from outside the network ie https://dinnerbone.com/minecraft/tools/status/ , it answers with the information …

any thoughts Hex?


#5

Hrm, this one’s tough. I haven’t had any reports of any behaviors anything like this, and I haven’t been able to reproduce it on my end.

Each time I have created a 1.8.9 server, the Players Online reflects exactly how many is on (which in my tests is usually just me). This reflects enable-query on and off that it works.

Have you ran npm install when you updated the webui?


#6

root@core games/minecraft# git fetch
remote: Counting objects: 16, done.
remote: Compressing objects: 100% (4/4), done.
remote: Total 16 (delta 12), reused 16 (delta 12), pack-reused 0
Unpacking objects: 100% (16/16), done.
From https://github.com/hexparrot/mineos-node
110c591…813ba3d master -> origin/master

  • [new tag] v1.1.3 -> v1.1.3
    root@core games/minecraft# git merge origin/master
    Updating 110c591…813ba3d
    Fast-forward
    html/index.html | 1 +
    mineos.js | 8 ++++++±
    server.js | 82 +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++±-------
    test/test-mineos.js | 13 +++++++++++++
    4 files changed, 95 insertions(+), 9 deletions(-)
    root@core games/minecraft# npm install

but when i reload the web interface, i still see

git commit: 110c591


#7

ok figured it out …

Stopped and restarted mineos via command line.

git commit: 813ba3d

No Change, still show 0 players online …

Any other thoughts?


#8

OK …

Interesting discovery …

So current setup , i have 2 servers , to do that, i had to put in 2 ip address on the server for the mc servers to use. using 1 ip would not work as even if i set the port for the 2nd server to 25566, it always said the port was in use, even tho netstats did not show it in use. so i put a second ip on the server, then set each server to there own in server properties and to default port of 25565.

I didn’t not realize at that time that the “players online” stopped working, and the “player Interaction” stopped showing up …

so upon testing i shut down the 2nd server, changed server 1 ip back to 0.0.0.0 and started it up.

Now players online is working and so is player interaction. 1 other thing which i find interesting, our local web site on the server, i had to change the server status widget back to 0.0.0.0 and now it shows players online also … if i change it back to the server ip i get ) players even tho 1 is logged in.

So i have narrowed it down to the use of separate IP addresses for each server.

  1. Why do you think MC would stop local query of IP when using static?

2 If we have to stay with 0.0.0.0, then how do we fix the port problem, that it says the port is in use when netstat says it is not.

Thanks Will …


#9

Fixed … a bit more research … found that java was defaulting to ipv6 (even tho disabled in networking). Added in “-Djava.net.preferIPv4Stack=true -Djava.net.preferIPv6Addresses=false” in to server properties. and now i could fire up 2nd server on same ip using a different port.

so i would consider the issue resolved. Thanks for you help Will.


#10

I’m sorry to bring this post back from the dead, but I’m also having the same problem.
I’ve added the same line no my server.properties file, and it still doesn’t count the players
they always show 0.
any insight?


#11

I think he meant he added it to server.config, because that file actually has the JAVA_ARGS line this would be added to.


#12

cat server.config

[java]
java_xmx=256
jarfile=forge-1.12.2-14.23.4.2703-universal.jar
Djava.net.preferIPv4Stack=true -Djava.net.preferIPv6Addresses=false

[onreboot]
start=false

[minecraft]
profile=1.12.2-recommended
broadcast=true
unconventional=false
commit_interval=15

Unfortunately I didn’t managed to solve it



#13

image


#14

Tried it, and now it simply doesn’t start
image
and the file is


Also set the enable-query=true (it was false)
(edited)
And this is may ss command output, before and after connecting from a client (without anything written on the “Additional Java arguments”)


#15

In both instances you have typed:

Djava.net.preferIPv4Stack=true -Djava.net.preferIPv6Addresses=false

instead of:

-Djava.net.preferIPv4Stack=true -Djava.net.preferIPv6Addresses=false

edited original posts of OP, as he had made this mistake too, but probably only in his reporting his solution, rather than what actually worked for him.


#16

(I’m spending my entire book of curse words… &$/&/&(/%%/$#"%%$"&/)(=)
It now runs, but still no users in the online counter …


#17

9 times out of 10 this is actually caused by a modded (non-vanilla) server reporting user counts differently than MineOS expects. It’s been tested on vanilla, various sponges and spigots, and a whole host of different server softwares, but some mods (namely forge, but others too) can change their player-count reporting format.

Can you fill me in on what server pack you might be using so I can test it?


#18

jarfile=forge-1.12.2-14.23.4.2703-universal.jar was the only thing I’v chosen

I’ve chosen Forge, because many of the mods I liked will require forge, but at the present time I haven’t even applied any mod . To be honest haven’t got to that yet.

I have a minor understanding of linux systems, but my minecraft level is even lower than that
lol

That was supposed to be my next step, to apply mods…
image


#19

I’ve changed the profile, to test if it could be something related to that

No luck…