So I have been using MineOS for a while, I just imported a big (15gb zipped) Minecraft Server into MineOS and it worked properly, however the WebUI stopped responding so I reloaded the page and now it comes up with the error:

This site can’t be reached
xxx.xx.xx.xx refused to connect.


Checking the connection
Checking the proxy and the firewall


I looked in the IPTables to see if my IP got blocked and that isn’t the case, I also looked if port 8443 is open and it is, I’ve checked the mineos logs and I can’t see anything wrong really, however I may be overlooking the errors that are in my face. Also, I am connecting with the correct address eg: https://xxx.xx.xx.xx:8443/admin/index.html

The WebUI was working perfectly before, and now it just stopped on me. Also, if I use the top command node is at the highest CPU usage (i’m guessing that’s normal though?)

2949 root      20   0 1364384 218660  10864 R 105.1  0.3   0:10.15 node
1 root      20   0   33560   2876   1436 S   0.0  0.0   0:01.10 init

Small update:
(yes I know windows troubleshooting can be unreliable) but it says
The remote device or resource won’t accept the connection

Another small update:
Not sure if this matters at all, but I recently added a CAcert to php.ini configuration for website stuff, however I can remove it because I’m not using it anymore if it’s possibly causing a problem.

Another update:
I deleted the mineos.log file and tried the website again to load another log file, website still disconnects and I got some new logs, Here is the log: http://pastebin.com/i3TDAtcz

I fixed the problem. The problem was that I had improper profile names in the server.config file in some of my servers because I imported the servers. I feel stupid now, but all is good!


Thank you for providing the solution; I’ll look into fixing this behavior–even an improper profile name shouldn’t kill the webui, so I’ll see to it that it gracefully handles imports like this in the future.

1 Like

Can you provide any relevant errors from /var/log/mineos.log? It’ll help make sure my commit fix handles all cases.

I myself can’t see any errors in the log, however this is all it spat out continually until I fixed it: http://pastebin.com/MBhbBZ54