[SOLVED] Modpack (FTB Infinity) not loading up

Whenever I load the forge server jar it will work fine, but when i add mods, in the webui it will say online for a few seconds and then go offline. There are no logs in the log folder of forge. Please help me
This is what my server folder looks like

EDIT: Did some digging and figured out a solution

Was the solution something that could help future visitors?

Would like to know as well … FTB Infinity profile ok, download ok, eula accepted, but server not booting up

one Must run the FTBInstall.sh after server creation for your newly created server to function.

I was trying to short cut it so I ran the bat on my windows machine and uploaded the minecraft_server.x.x.xx.jar to my profile dir. Since I’m the only one creating servers I feel like I can accept it once and be done with it, I also edited the eula.txt so all the servers I make have that auto accepted. which works fine.

But short cutting the FTBInstall.sh doesn’t and must be done after server creation

I hope this was the step keeping you form getting your Infinity server from running

Here is your shortcut:

login terminal as root

chmod +x FTBInstall.sh
chmod -R 777 /var/games/minecraft/servers/

Then start in web gui.

777 might be overkill. “other” certainly doesn’t need all those settings. And +x also is a bit redundant if you’re recursively chowning all of the servers directory. Start small, and work incrementally and it should leave for a cleaner, safer FS.