[SOLVED] Guide for unbuntu server 15.10 node install?

trying install on a ubuntu server here.
the guide asks me to use curl? which returns an error.

i also want to use not openjdk but the acutal oracle java. because this gives me a lil better control over memmory.
what arguements should i use during the install for oracles java instead of open sdk?

also im finding that i cannot install npm it faiels with configure errors

Here’s the guide for Ubuntu 15.

Or, you may try my adapted steps below (includes Oracle Java 8, copy and paste friendly)

1: Sudo into root

sudo -i

2: Create and use a temporary directory for installation

rm -rf /tmp/*
mkdir /tmp/setup
cd /tmp/setup

3: Preparing dependencies (adding the Oracle Java 8 PPA Repo to the system)

add-apt-repository ppa:webupd8team/java

4: Installing dependencies

wget https://deb.nodesource.com/setup_5.x
chmod a+x ./setup_5.x
./setup_5.x
echo oracle-java8-installer shared/accepted-oracle-license-v1-1 select true | sudo /usr/bin/debconf-set-selections
apt-get -y --force-yes install nodejs git rdiff-backup screen build-essential oracle-java8-installer oracle-java8-set-default

5: Installing MineOS-Node

mkdir -p /usr/games
cd /usr/games
git clone https://github.com/hexparrot/mineos-node.git minecraft
cd minecraft
git config core.filemode false
chmod +x service.js mineos_console.js generate-sslcert.sh webui.js
npm install
ln -s /usr/games/minecraft/mineos_console.js /usr/local/bin/mineos
cp mineos.conf /etc/mineos.conf
cp init/systemd_conf /etc/systemd/system/mineos.service
systemctl enable mineos
cd /usr/games/minecraft
./generate-sslcert.sh
reboot

A reboot shouldn’t be necessary, however I do recommend it (if you don’t wish to reboot, don’t copy the reboot command at the end of the script)

Once finished, the MineOS-Node Web UI should be available on https://“ip”:8443 (replace “ip” with the IP). In the event that something goes wrong, chances are that it was during the install of the UI, and these extra steps should be followed:

1: Sudo into root:

sudo -i

2: Updating/resetting MineOS-Node Scripts:

cd /usr/games/minecraft
git fetch
git reset --hard origin/master
rm -rf node_modules
npm install
chmod +x mineos_console.js

The MineOS-Node WebUI should now be available on https://“ip”:8443 and if it still doesn’t work, repeat the “Installing MineOS-Node” section, and if it doesn’t work, try again from up top. Occasionally something might not work/install, so you may need to retry. Let us know how everything goes!

1 Like

this fails at hte step npm install
with
npm WARN package.json dae,pmoze22±4-2 mp repository field

then down the line /bin/sh 1:node not found

call to node-e "reuiqre*(‘nan’ ) etc. .

node latest version is installed. so im a bit confused as to what im missing

ok, so the npm was fixed by removing nodejs, the legacy version and npm, and reinstalling both as per instructions.
(might be an idea to add this as an option to the guide itself? or as an added step if having issues)

now im getting stuck at the ui. will scour forums for more info.

Error: Cannot find module ‘…/encodings’ at Function.Module._resolveFilename (module.js:339:15) at Function.Module._load (module.js:290:25) at Module.require (module.js:367:17) at require (internal/module.js:16:19) at Object.getCodec (/usr/games/minecraft/node_modules/body-parser/node_modules/iconv-lite/lib/index.js:61:27) at Object.getDecoder (/usr/games/minecraft/node_modules/body-parser/node_modules/iconv-lite/lib/index.js:118:23) at getDecoder (/usr/games/minecraft/node_modules/body-parser/node_modules/raw-body/index.js:44:18) at readStream (/usr/games/minecraft/node_modules/body-parser/node_modules/raw-body/index.js:218:15) at getRawBody (/usr/games/minecraft/node_modules/body-parser/node_modules/raw-body/index.js:106:12) at read (/usr/games/minecraft/node_modules/body-parser/lib/read.js:76:3)

ok, a reboot after trying the last few changes again, solved the UI issues. so it is needed. the guide helped me a lot, thankyou!

now i have my mumble working together with oracle java, and the node implementation of mineos.

trying to figure out how to add the server now.
(some files are not downloading the way they are meant to - 1.7.10 forge)