[Solved] Forge/FTB No Start No Feedback


#1

[Note: As a control I followed the same steps on my local machine. the server is at my brothers house].
So we had a turnkey running and got a much better server lots of ram and processing power sow we are migrating over. Turnkey had problems with a missing driver for a Ethernet card on the new server. So we installed linuxmint [18.3 64bit] and built the mineos and node on top [git commit b28c5be says it is the newest when updating].
On the server I can run a standard minecraft server fine. I can choose a forge latest or recommend and the installer will become an option and I can run the installer. When I select the universal file and choose start nothing happens and I mean nothing no feedback at all, nothing in the log [still shows the last run]. Absolutely nothing happens. [I have tried downloading and pushing up the universal jar files manually as well with not luck]
Now I do the same thing on my local computer and the universal starts and runs, I can log into it [all locally or course though].
We had the previous server set up to use everything as root, going to try that later today and see if that is the problem. Maybe forge requires more permissions to run than a vanilla minecraft. After that I’m guessing a complete rebuild may be necessary, just not sure.
EDIT: Tried installing direwolf20 as well, everything goes as expected right up to selecting the universal file to run then nothing.


#2

Don’t know if this is helpful or not, I had / having the same issue trying to run the latest Build tools for spigot. What I found was a text file in the server folder named the same as the Jar file. It showed a log detailing the lack of permissions and why it couldn’t run. Maybe you have something similar? Might bive you an idea as to whats happening.

And yes I agree, No feedback sucks. Anything would be helpful rather just leaving us hanging.


#3

MineOS starts servers by creating a “screen” session, which is a detached terminal that runs the java + jar for the user.

Because it is a detached terminal, MineOS cannot tap into the stdout–or, the output that gets put to the screen for normal operation.

That said, here are the biggest things to look out for:

  1. nothing should ever be run as root. 9/10 times when things really don’t work, it’s because root somehow was introduced into the workflow. Whether it was manually extracting files as root, editing files as it, or running the server jar even once as root, this changes permissions to root that will make all attempts for non-root to do anything, like start servers, to fail.

You can verify this by checking ownership of files in /var/games/minecraft/servers

To rectify this, using the terminal session, use chown, such as chown -R mc:mc /var/games/minecraft/servers/[servername]

  1. if the webui is too hard to navigate when it comes to Forge/FTB, the alternative should instead be to log in as the non-root user into the terminal and run java and the other install commands manually. Ultimately, MineOS is only going to need to run one jar to get the server running, so all the preparation jars (such as the installer jar) can be run without the webui entirely.

  2. Lastly, just check out the file contents directly. Are there steps for how the server should be started? Is there evidence that the webui attempted it like you expect? Because if all else fails, Java should still be able to run the server manually–and all you need to do is ensure it runs with the appropriate non-root user before attempting (repeatedly) to get the webui to handle the full workflow.


#4

Used the alternatives java command and changed over from openjdk and to java 1.8.0_191 it now runs it all. I would look further but at this point it seems to be working and I’m through beating my head on the wall. Moving on to other fish that need frying.
Thanks for the help. Hope this helps someone else.