[SOLVED] Forge downloads through UI not all working

many of the forge versions, are not downloading, the downloads are marked as downloaded, but the message pops up saying it did not work.

specifically latest and recommneded for 1.7.10

To be honest, it’s the requirements of installing Forge…you have to download the Vanilla Minecraft Server jar as well as Forge, then open the Vanilla jar, delete a folder, then drag the files from the Forge jar over into the Vanilla jar. Forge’s auto-installer for servers still only downloads Forge and the Vanilla jar and leaves the rest of the work to you (modifying the vanilla jar with forge files). The reason Spigot/PaperSpigot works is because it actually builds a server-ready/complete Minecraft Server jar, which can be run right after it’s process if done.

Easiest Solution: Download the Forge auto-installer on another computer, select server install and choose a directory; when complete, open the Minecraft Server jar (open, not run) and delete the “META-INF” folder, then open the Forge jar and drag-n-drop the contents into the Vanilla jar. When complete, you now have a Forge Minecraft Server jar, which you can now just drag-n-drop into your server’s base directory (if MineOS doesn’t show the jar, click on your username and refresh server list then try again)


i just downloaded forge install jar manually, put it in the directory, ran with the -Installserver command.

Then switched the jar file to the new one created and poof it worked.

(sorry for late reply have been completely unable to access this site fora while)