[SOLVED] Create Server Error

This issue was brought up in a previous thread covering a couple of different problems so I gave it it’s own topic.

Running MineOS in VB running on Ubuntu 12.04 host. 10GB ram and 10GB hdd allotted for MineOS.

After installation I added two users and added both to MC group.

Created and updated stock vanilla profile successfully.

When I try to create a server under any group I get Create [error] message in red pop up box.

/var/games/minecraft/servers/servername is empty and the server does not appear on the dashboard. I’m not sure where to start looking.

Thanks in advance.

I saved a txt file to one of the empty server directories and it saved it with no issue. I’m wondering if it’s a permission issue?

when you saved the text file, as what user did you do it?

Did you do it as root? And if so, have you done any other filesystem actions as root that may have messed with permissions?

Does /var/log/mineos.log have any additional information of each of your attempts to create a server?

txt file saved as raul

apt-get install htop, sudo, usbutils,locate
adduser raul, braden
usermod -a -G mc,sudo (added raul and braden to mc group, added raul to sudo group)
sudo apt-get update & upgrade


I know I created one of those servers with the mc option, I’m not sure why it isn’t listed that way.

/var/log/mineos.log has no entries past 19 Jan, even though I tried creating a server as I was writing this reply. Here is the entire result for cat /var/log/mineos.log


You probably noticed there are only two days worth of entries.

1 Like

Unrelated question:

Do you prefer screenshots directly in the reply or as an external link? I’m not sure what’s policy for MineOS Forums.

Here is best–there’s no policy set in place other than “make it as easy as possible for others to get the information to help you”

Question: Is your Cruzer flashdrive mounted all the time? I’m not yet able to discern what is causing your issue but one potential cause might be is if the archive/backup directories aren’t always mounted.

From the screenshot, it appears to be (ubuntu would red-link it if it were broken, right?), but if it weren’t the issue is that MineOS searches all the directories in {backup,archive,servers} to find the names of all available servers. A broken symlink might break the operation.

Second thing: In your javascript console (often F12), what is the error reported when you attempt to start the server?

Even though you only see the red pop-up, more detail should be outlined in the javascript console, hopefully which will better pinpoint what is going wrong.

Tertiary point, it’s kinda weird the variants you used for vanilla (some uppercase V some not, some with numbers (starting at 1!) and some ending with dots. No, this wouldn’t have any technical downsides (but it seems like it would make typing/auto-completion more complicated!)

Sorry for the delayed response, weekends are actually the hardest time for me to get time to work things out; we’ll figure it out.

Unless there is a reboot of some kind, yes. For some reason with VirtualBox the USB drive has to be removed and plugged back in after a reboot, at least for me anyway.

I’m not sure about that. This is my first experience with symlinks. Just to clarify the situation a little, I’m not running MineOS on Ubuntu, I’m running MineOS Turnkey in VirtualBox, which is running on an Ubuntu host.

Tried to create a server and I got:

Object {cmd: “create”, result: “error”, payload: “”} scriptin.js:747

I’m using vanilla to make sure everything works. FTB is, in the short time I’ve been doing this, a pain to set up. So babysteps.

I appreciate the response.

Alright, I think we need to try it from command line and hopefully it’ll spit out more information for us.

root@core games/minecraft# python mineos_console.py -s newserver create
{create} completed successfully.

As root, create newserver. Errors should be more explicit here in command line and maybe it’ll let us know exactly where it’s failing in the creation.

If not, I think the appropriate backpedaling steps is to return the {archive,backup} directories to directories rather than symlinks, but let’s try this first.

Good call on the symlinks. The same error showed up for the backup symlink as well. I removed the symlinks and created vanilla8 in the webui and it worked.

Sooo, how do I backup or archive to USB. Both for hdd space considerations and also to have a valid backup in case of a hdd crash or other system loss.

I think I read somewhere that rsync has issues with symlink or USB drives because of the “:” in the file name. I did not think this would apply to archiving though. It also did not dawn on me that it would affect server creation.

I wonder if it would work to create the symlink for archive after the server has been created?

The symlink you created should likely be A-OK, the only thing is that the archives and backups are being created as the user from the web-ui, so mc. If mc doesn’t have permissions on your flashdrive mount, then this error will crop up.

Either you a) chown the symlinked directory, e.g., /mnt/Cruzer/minecraft to mc, or b) you give o+w perms to it (so that all users, even those not the owner or group-owner) can write to it.

Alternatively, you could just write a cron that would mv the files from the normal on-HDD location to your flashdrive, but which option you choose is pretty much strictly preference.

The permissions for the USB drive are raul:mc 770, so I don’t think that was it. It might have to do with the format. I left it at vfat instead of ext3.

The archives worked in the past, I now remember having issues with the backups though I can’t remember exactly what they were. Worst case scenario I reformat the USB to ext3/ext4 and see what happens.

I reformatted the USB drive to ext4 and recreated the symlinks. Create profile success. Create server also successful.

I guess there’s a conflict somewhere with vfat.

1 Like