[SOLVED] Cant start spigot 1.12 server


#1

I’ve been trying to upgrade my bungee server to Spigot 1.12 and MineOS has not be happy in the slightest. I’ve updated the WebUI and had to reset it multiple times just get the UI to respond. I was able to download the latest buildtools and successfully built spigot 1.12, and was also able to copy the jar file to my servers from the spigot build page of the webUI.

However, when I go the server settings page there are no jar files in the executable jar files drop down menu. When I try to select a spigot profile the only option is the buildtools-latest profile, and even if I select this and click the copy files to server button nothing happens. Is there something simple I’m missing/forgetting to do?

System Info:
Arch Linux
node.js webUI


#2

Can you share /var/log/mineos.log with me? Typically this behavior is reported in the logs and lead us to the issue fairly quickly.

Feel free to PM it to me, if you prefer.


#3

Its literally just this:

Script execution started on: Wed Feb 28 21:59:37 EST 2018
Updating mineos-node repository…OK
Checking out master branch…M package-lock.json
Your branch is up to date with ‘origin/master’.
OK
Resetting directory to official contents…HEAD is now at 83a146a reversed order of archives so newest first
OK
Deleting npm module dependencies and rebuilding…
> posix@4.0.2 install /usr/games/minecraft/node_modules/posix
> node-gyp rebuild

make: Entering directory '/usr/games/minecraft/node_modules/posix/build'
  CXX(target) Release/obj.target/posix/src/posix.o
  SOLINK_MODULE(target) Release/obj.target/posix.node
  COPY Release/posix.node
make: Leaving directory '/usr/games/minecraft/node_modules/posix/build'

> userid@0.3.1 install /usr/games/minecraft/node_modules/userid
> node-gyp rebuild

make: Entering directory '/usr/games/minecraft/node_modules/userid/build'
  CXX(target) Release/obj.target/userid/src/userid.o
  SOLINK_MODULE(target) Release/obj.target/userid.node
  COPY Release/userid.node
make: Leaving directory '/usr/games/minecraft/node_modules/userid/build'
added 544 packages in 9.189s
OK
Setting node javascript files to executable...OK
Script execution ended on: Wed Feb 28 21:59:48 EST 2018

The log hasn’t had any updates since I last reset the UI. I cleared the log file before hand because it was significantly long, like 4000 lines long.


#4

Should I try doing a fresh install of MineOS?


#5

Can you confirm that non-spigot servers work?

Because if the problem only appears with the spigot server present, then I think we’ve identified the problem: MineOS + that spigot server.

If the above is true, then no, a fresh install wouldn’t help. Relocate the server away from /var/games/minecraft entirely, like in your user’s /home directory. Primarily concerned with /var/games/minecraft/servers/servername, not as much the archives/ and backup/.

If we can determine it’s specifically that Spigot instance, then you’ll probably want to share the server with me. I wouldn’t need the world files (so it should also be a small file, in general), but I would need the combination of your server jar and the accompanying mods. Then I can definitively test where the failure is happening that MineOS is stalling with.


#6

Found the problem and it was real dumb on my part. I did a full system reboot and now it works fine. Id guess that a recent system update affected one of MineOS’ dependencies, which reloaded after the reboot. Thanks for putting up with my noobness :stuck_out_tongue: