Solution to unable to login to WebUI

So I encountered an issue where I couldn’t log in to the WebUI after installing MineOS on Ubuntu 22.04, and I came here and found several people having the same issue. I don’t think I saw anyone specifically with Ubuntu 22.04, but the issue I believe will be common among most modern Linux distros. As several posts have pointed out, the issue is the hashing algorithm used for the user you are trying to log in with. The distro uses something other than SHA512 which is what MineOS is expecting.

Reason for posting this is I never saw anyone post a simple solution and I seem to have found one. Assuming you created a new user to login with (you should, don’t just use the default or root!), then you should be able to resolve the issue by the following command (run as root):
echo '<user>:<password>' | chpasswd --crypt-method SHA512
Replacing with the user you created (adduser <user>) and with the password you supplied when creating the user (or a new one, I believe). Now try logging in with the username and password used in the command and it should work!


Sorry it seems i misread your post i have a habit of being online late at night and skim reading around those times.

good solution.

at first i didnt expect this to work as it said “no permission” when i executed the command, but i just added sudo before it and it worked perfectly! tysm!

I wish I had found this sooner… not sure what happened, but my WebUI stopped responding to any login attempts after I had to reset my admin passwords. After backing it up and taking days to try and reinstall it, it still wasn’t accepting password prompts… This solved my issue. Good lord the headaches are over and my kids can get back to their games.