SkyFactory 3 Upgrade to Mine OS Please help!


#1

OK, Ive been reseaching the activity and I did an upgrade to MineOS and the Webui before I started this, which incidentally seemed to go just fine.

But now im stuck…like really stuck!. I downloaded the latest Skyfactory 3 Jar file from the profiles page…all good
I opened a putty session to did a Serverstart.sh command as many tutorials say becasue apparently you cant just start this from the Web ui as I found out.

This was a disaster to say the least. while I managed to get Skyfactory 3 v3.0.15 yup and running, I could not load the worl backups for players to continue there games. all I could get was what was in the inventories and thats it. all of the players bases have vanished. I tried reloading three or 4 world backups, all the same. Checked the Level.dat file, no difference.

Where am I going wrong???

Now I tried winding the game back to the backup I made before I started this fiasco and now the server wont start at all. It goes up for a minute and then shuts down. This from what I thought was a working version of the server. I really need some help here.

Im finding the webui a real pain too as when I try to read the console as it loads, it stops after certain time and want me to refresh the page because of some overloading lines or some rubbish. when I refresh, I lose everything.


#2

What user did you run this as? Was it the same user that you log into the webui as? Can you confirm you never ran it even once as root?

Could be explained if the ownership got changed to root–or other activities were done on server files while that user.

Also a common symptom of running the server as root.

The webui uses memory to try to feed live logs to the user. If you need actual, full logs, you can simply read the file from the shell; it’s in the server’s live directory, e.g., /var/games/minecraft/servers/myservername/logfilename.log. The logs aren’t lost, they’re just no longer shown past a point because, again, loading files in the webui is a memory/disk load even if you’re not reading it actively.

The page stops loading if it loads over 160 lines in 2 seconds, which is also an enormous load on your browser (and often it’ll start bugging out when your desktop runs low on a bloated browser. Anything slower is likely to be more manageable, hence the threshold.


#3

I ran the putty as root.

I tried to run the server from the WebUI when i first installed the upgrade, but it doesn’t work. the reason that I can see is the files weren’t copied over into the live folder. moreover they weren’t even created in the profiles folder. when I started the server as Root in the putty session. it created the files in t he profiles folder. I then shut the putty session down and copied the files into the live folder from the webUI.

After that, I simply replaced the World folder with the backup I made before I started. Its then that I started having the issues with the server not starting.

and thanks for the explanation of the log screen. it does explain some of the errors that I have managed to read.

I did manage to wind the server back however and restore the game. I haven’t been able to update the mod pack yet. although I now know to download the jar file from the profiles list in the first instance. From there however, im a little gun shy as to what to do next after the fiasco I just went through.

After much reading, I tried to change the level.dat files. that didn’t work as I still have no bases showing. Finally in some obscure page, It was suggested I delete the ‘Session.lock’ file and try it then. I’m not sure exactly what that file does, but that worked for me and all of the bases loaded from a backup.


#4

You likely then created a LOT of minecraft files (or re-owned them) to root. But when you log into the webui, you’re trying to do things as mc (or minecraft, or any user that isn’t root).

And as Linux permissions work, if a file is owned by root, it often cannot be changed by non-root users, which would also explain why Minecraft would try to start, attempt to modify a file (because the server does that), get a permissions error, then quit out.

So you need to chown these files–any files and the directories that share the name of your server–back to your non-root user.


#5

OK, that makes sense.

Is there a better way to update a modded MC server? i.e. doing it from the web ui rather than having to putty in and run the server, then chown the files then copy the files across to the live folder etc etc? Or am I stuck with following a 20 point step process using 5 different programs. (Yes I’m exaggerating to make a point, that being its a painfully long process for upgrading a modded MC server atm).


#6

Zip up the working server from wherever you have it, place it in /var/games/minecraft/import and then go to the Import Server tab.

Needing to upgrade an existing server (in MineOS) to a newer modded version?

Log in with putty and don’t log in as root–just mc (or minecraft or whatever user). Then permissions are maintained.


#7

OK, so that answers my last question. you do need to run the server from Putty first…Oh well… Ill persevere with that. When you say “Zip up” the working server. Do you mean

a) do and archive from the WebUI, or
b) download all the files via ftp, zip them up manually and then re upload to the /import folder.

If its option b, is there a specific name I have to use for the zip file? or will it just over write the current server. Just trying to cover all my bases here as I do not want a repeat of my last effort. Here’s the process I have so far: (Question marks mean I think there may be some info missing)

  1. Backup your server files, Zip them up and name them ??? then re upload them into the /Import folder via FTP
  2. Download the latest Jar file (updated mod pack) from the profiles list. This will add it to the profiles folder.
  3. Open Putty and log in using the MineOS user name and password (NOT as root). Let the server run.
  4. once the server has finished loading, stop the server from putty and close the session.
  5. Go back into the WebUI and…???Import the files from the import tab? Copy the files across???

not sure where to go from here…

Thanks for taking the time too…


#8

Why?

I know the file exists, and I know you can start the server with it. But my question to you is do you really need to run Serverstart.sh?

What does Serverstart.sh do?


Here’s what I did to get a brand new SkyFactory3 server up and running.

  1. downloaded FTBPresentsSkyfactory3-3.0.15-1.10.2.zip.
  2. copied the file to /var/games/minecraft/import
  3. entered the webui as mc, clicked “Import a server”
  4. gave the server a name “SB”
  5. went to the server-at-a-glance page. Clicked “FTBInstall.sh” in the webui.
  6. Changed the server dropdown to FTBserver-1.10.2-12.18.3.2477.jar
  7. Pressed ‘start’

So you might say, "but I already have a working server on my desktop, can’t I just use that?

Yes. Because now all you have to do is:

  1. copied the zipped file to /var/games/minecraft/import
  2. entered the webui as mc, clicked “Import a server”
  3. gave the server a name “SB”
  4. went to the server-at-a-glance page. Clicked “FTBInstall.sh” in the webui.
  5. Changed the server dropdown to FTBserver-1.10.2-12.18.3.2477.jar
  6. Pressed ‘start’

So it’s clear, you should read ServerStart.sh and what it does. It does nothing special; in fact, it does nothing MineOS can’t already do and does.

It loads filenames from settings.sh–things you do in step #5.

It sets Java arguments. Things you can do at step #4.

But mostly, it sets Java arguments you don’t even need/want. Here’s what happens when I run ServerStart.sh

mc@mineos servers/sb$ ./ServerStart.sh
Starting server
Java HotSpot(TM) 64-Bit Server VM warning: Ignoring option PermSize; support was removed in 8.0
Java HotSpot(TM) 64-Bit Server VM warning: Option UseParNewGC was deprecated in version 9.0 and will likely be removed in a future release.
Unrecognized VM option 'CMSIncrementalPacing'

It ignores a setting ServerStart.sh “Permsize”…a setting removed in Java 8. It ignores a setting “UseParNewGC”…a setting that Java is discouraging use of. It ignores a setting ‘CMSIncrementalPacing’–a setting that doesn’t even work.


If you want to use convenience scripts, you can use them–but they don’t co-operate with a convenience web user interface. You choose one or the other.


#9

Above, in answer to your question “Why?” I’ve been trying to get a good answer for a while now on the best way to upgrade a server. As can be seen in this thread my first attempt was nothing short of a disaster, which makes it pretty clear that I have a LOT of learning to do. I would like nothing better to do than to avoid using putty altogether. SO I guess we’ve been mis-interpreting our threads. it happens in the written style of discussion. I was under the impression that your comment quoted above meant that start the server under putty was a mandatory thing. Obviously this is not the case and I’m so appreciative that you cleared that up.

I am curious on one point though if I may, that is you mentioned that I “zip up” the working server into the import folder, and then import the same files under the same server name that you just zipped up. (Steps 1 to 3) wouldn’t that just overwrite the same files and you end up back where you started? Is there something that the import function does to change the files that I’m missing here? Reading through your post, I’m obviously confused as to the “zipped file” you are referring. Or is the zipped file you’re referring to the new Skyfactory 3.0.15 jar file? which would make more sense.

I don’t mean to be a pain here, I just want to be absolutely clear on the steps that you have provided before I try this again.