Servers not showing up


#1

Hello,

I have recently installed MineOs and I had all my servers installed. But when I checked the next day the server folders were gone (not because of MineOS). They were still in the backup folder, but when i tried to put the servers back in the servers folder they were not showing up. Also new servers that i created are not showing up either.


#2
  1. What version of the webui are you using (python or node)
  2. what did you do to ‘put the servers back in the servers folder’
  3. does /var/log/mineos.log show anything?

#3

I use python, i tried putting them in the folder, i tried making a new server and transporting the files to the new server and i tried importing the server but all without succes. the only error is see is this:

http://pastebin.com/dfq91gCj


#4

did this succeed?

Were you using the correct user, e.g., not root but your webui login user?

There’s no error here, because it doesn’t appear to be a web-ui related issue–or at least it doesn’t know that it’s not behaving the way you expect it. Ownership matters and would explain no error message and not seeing a server. How exactly did you try moving the files over?


#5

No unfortunately it didn’t work, i did use root but thats because I cant find the permission file and when i try ftp it says: Permission Denied.


#6

What didn’t work? I just explained by using the wrong user would make it not work, so I’d need to know what you actually did, preferably with details on how you did.


#7

As i have said, i tried to put the servers back in the main servers folder (using root ftp) and i also tried to make a new server but even the new server wasn’t showing up. It does make the files but its just not showing.

Btw how can you edit the user permission?


#8
root@willonubuntu:~# cd /var/games/minecraft/servers/
root@willonubuntu:/var/games/minecraft/servers# ll
total 16
drwxrwxr-x 4 root root 4096 Jan 20 14:39 ./
drwxr-xr-x 7 root root 4096 Jan 20 09:03 ../
drwxrwxr-x 5 will will 4096 Jan 20 11:18 asdf/
drwxr-xr-x 4 will will 4096 Jan 20 14:40 fff/
root@willonubuntu:/var/games/minecraft/servers# chown -R bill:bill fff
root@willonubuntu:/var/games/minecraft/servers# ll
total 16
drwxrwxr-x 4 root root 4096 Jan 20 14:39 ./
drwxr-xr-x 7 root root 4096 Jan 20 09:03 ../
drwxrwxr-x 5 will will 4096 Jan 20 11:18 asdf/
drwxr-xr-x 4 bill bill 4096 Jan 21 09:23 fff/

asdf will only show up in the webui if logged in as will. fff will only show up in the webui if logged in as bill.


#9

unfortunately it didnt work :frowning:


#10

What didn’t work?

You need to provide us with exact command you’re executing and output–or our help is completely blind and will be fruitless and frustrating.


#11

We will be reinstalling mineos


#12

I have the same problem,
My servers are not showed on the webui of mineOS.


#13

If this is an issue for you, please feel free to open a new thread instead of reviving older ones. Many reasons could explain servers not showing up, ranging from “you’re logged into a different user than the owner of the server” to “using an irregular mount location.”

Since the explanations (and solutions) vary so widely, it’d help to have more information about what servers exist:

ls -la /var/games/minecraft/servers/

as well as whether the listed owners there match the user being logged into the webui.


Server are not in the web UI
#14

WebUI not showing servers