Servers Not Populating

I was having more issues related to the web-ui taking ages to load again today… I found some information on the wiki that said that I should update my scripts, I did, with no success. I then decided to reset my scripts, which completely broke my console system entirely.

I have been working on some other projects on my machine recently and have determined that my issues likely stem from a differing nodejs version. I tried to update, with little to no success. I then removed it entirely and reinstalled. No matter what I do, I am being 404’d on the install and cannot get node 10.x installed. I was able to execute “n 10” and it set the version to 10.x, but now mineos cannot recognize the new location (/usr/local/bin/node) and is demanding it be installed in /usr/bin/node. I’ve tried as many things as I could, but I’m throwing in the towel. This error is reoccurring through all of my attempts. My mineos log was too large to post to pastebin itself, I can send it alternatively if needed.

Depending on your installation, you’ll need to make a modification to the service scripts. You can see a list of them here:

For example, if your installation uses the systemd init system, then you’d be looking to modify /etc/systemd/system/mineos.service.