Server won't start at all

Hi, I recently tried using MineOS and everything went fine through the installation process but afterward when on the WebUI I would fill out all the necessary spots and it would not start at all. It doesn’t even ask me to accept the EULA. I saw something similar: Servers wont start to this here but otherwise I’m lost

If you navigate to the server’s directory (/var/minecraft/servers/*server-name*/ does the EULA get generated? Which profile will you use? Do you have any values set in the Xms field? Also, the /var/log/mineos.log could help shed some light as well.

Hi, sorry i took so long to reply. How is it i get to the director? Do i use PuTTY or “Shell In A Box”? Or do i use Webmin? I used the 1.16.1 profile and my xms is set to 256, my xmx is set to 2048 if that helps. Is the mineos.log also in the directory if i manage to figure out where to get to it?

I recommend using PuTTY as it is lightweight and fairly intuitive to use. But first off, before using that, clear the Xms field and try to launch the server.

I have found that the Java heap minimum is not required, and it tends to fail any server to load.

The log file is stored in the /var/log directory. You can access it using FileZilla.

At a certain point, Minecraft servers started requiring a newer version of Java. It could be that your Java is out of date. One way to check is:

  1. can you run a 1.12 server?

If that runs, then indeed, this is a Java-too-old issue. Java can be updated with the command line.

Did you use an older version of the MineOS ISO, or the most recent one? Or is your build running on a different distro?

This link can help upgrading your Java if it required, like @hexparrot mentioned. However, first check if JRE or JDK is installed. Then follow the appropriate steps.

Edit: here’s the link

I tried a 1.12 server and it still didn’t start, it’s as if the start button won’t do anything

I’ve got a JDK 13 installed and a JRE from 2019, should i update these? The website link is meant for ubuntu and I’m on windows but ill still try it, unless I’m supposed to be installing it on the server

The Windows version of Java is for the game itself, but the server is using Java for the Webui. My MineOS runs OpenJava 1.8.0_252, and that link will work with the Turnkey version as well, they are both based on the Debian build.