Server Won't Start Any World


#1

My MineOS server has been chugging along nicely for well over 18 months, hosting about a dozen different worlds in that time. I was adding a new world to my server today when I found out the drive was almost full. I ended up removing 230+ archives from one world and deleting four other worlds that were no longer in use.

After creating the new world which I was originally planning to do, I found out that none of my worlds would start – including the one that has been running for over a year! I removed the new world, updated all my packages (including kernel and OpenJDK 7 upgrades), and rebooted. Still no luck. I tried using the current profile (‘vanilla186’) on my long-running world (‘Creative’), and when that didn’t work, I made a new profile (‘vanilla187’) and still had no luck in starting any world.

I dropped to the console and ran this command:

/usr/bin/java -server -Xmx896M -Xms256M -jar /var/games/minecraft/servers/Creative/minecraft_server.1.8.7.jar

The output was as follows:

[00:30:15] [main/FATAL]: Failed to start the minecraft server
java.lang.NullPointerException
	at com.google.common.base.Preconditions.checkNotNull(Preconditions.java:213) ~[minecraft_server.1.8.7.jar:?]
	at com.google.common.collect.Lists$ReverseList.<init>(Lists.java:767) ~[minecraft_server.1.8.7.jar:?]
	at com.google.common.collect.Lists.reverse(Lists.java:759) ~[minecraft_server.1.8.7.jar:?]
	at lt.b(SourceFile:156) ~[minecraft_server.1.8.7.jar:?]
	at lt.<init>(SourceFile:43) ~[minecraft_server.1.8.7.jar:?]
	at net.minecraft.server.MinecraftServer.<init>(SourceFile:168) ~[minecraft_server.1.8.7.jar:?]
	at ko.<init>(SourceFile:53) ~[minecraft_server.1.8.7.jar:?]
	at net.minecraft.server.MinecraftServer.main(SourceFile:689) [minecraft_server.1.8.7.jar:?]

Needless to say, my server is now as useful as a paperweight, but I don’t know enough about Java/OpenJDK to understand these errors. Any assistance would be greatly appreciated!


#2

I should also add that this is my memory situation:

             total       used       free     shared    buffers     cached
Mem:          1947        274       1673          0         18        107
-/+ buffers/cache:        147       1800
Swap:         1979          0       1979

#3

Is that the full, complete output from your java command? If possible, please include every line from the start of the command.

In addition, what user did you run that command as–was it the same unprivileged user as the one you log into the web-ui with?

Do you get the same error when you run that command with the 1.8.6 jar?

Also, does anything change if you use the nogui argument at the end of your command?


#4

Have you actually downloaded the jars before trying to run the profile?


#5

http://www.minecraftforum.net/forums/support/server-support/2449144-java-errors-trying-to-start-server

Seems you’re not alone, but there’s not much out there, either, in terms of the why it’s happening.


#6

That was the whole output.

Yes the mc user.

Yep, same error.

I didn’t try it with the -nogui argument.

I’m not trying to be dismissive with my answers, because after typing the original post and comment, I decided to make yet another new world. This time, it worked – but the old worlds still wouldn’t load! So I decided to back up my “Creative” world and recreate it with a new server and the old files. It worked until I copied the old files back into the folder. So I decided to try just a few files here and there to see what was causing the issue.

When I got around to copying the server.properties file without any problems loading the world, I was baffled. I had now added all the same files from the old world - except the actual world files in their folder - and it was now working again. I can’t assume the world data would cause Java errors, so I hesitantly replaced the world files with my backups. To my surprise, it started up without any errors.

I don’t know what happened or why MineOS decided to not start any of my worlds for half a day, but I avoided complete backups and OS reinstall by just trying the “replace one thing at a time” method. Regardless of how it was fixed, I appreciate the assistance with my issue.