Server will not launch with new 1.13


#1

I have a MineOS running on unRaid on my home server.
It runs fine under 1.12.2 but now I’m trying to update to 1.13 and when I hit “start server” nothing happens at all.

Admittedly, I’m a bit new to this, but any help would be appreciated.
Thanks!


#2

I’m having the same trouble here, with 1.13. Not sure if I’m doing something wrong, and also new to this. I’ll update if I find anything out.


#3

Check the new .jar file that was downloaded. I had to go to (https://minecraft.net/en-us/download/server) and get the new 1.13 jar and place it in the /var/games/minecraft/profiles/1.13/ folder as well as my server folder. Hope that helps, mine started after doing this but YMMV.

–bacond


#4

I got mine working today using the following steps on a FREENAS iocage setup:

  1. Loaded Freenas webui
  2. Opened Shell
  3. Typed iocage console mineos (where mineos was the name of my jail)
  4. Typed cd /var/games/minecraft/servers/[the name of my 1.13 server]
  5. Typed wget -O minecraft_server.jar https://launcher.mojang.com/mc/game/1.13/server/d0caafb8438ebd206f99930cfaecfa6c9a13dca0/server.jar
  6. Refreshed my serverlist in the top right hand side of the mineos webui
  7. Opened my new server in the mineos webui and selected the newly made minecraft_server.jar from the list of available server files
  8. Started server

For none FREENAS peeps it’ll be similar steps, in shell or command line - get to the server folder and run step 5 :slight_smile:

Edit: If you navigate to /var/games/minecraft/profiles/1.13/ as per @bacond and use the instruction in step 5, you’ll be able to make more servers without needing to repeat any of this


#5

Big TY !! Have a great day!


#6

Can anybody fill me in here with the new download–

is the URL broken? Is mineos.log reporting anything?


#7

I got my TURNKEY Linux version working thanks to montymint’s steps. I ssh’d in to the linux and started on step 4 of the steps. Worked perfectly! Thank you all!


#8

looks like the url at mohjangs end is not what was expected?

https://launcher.mojang.com/mc/game/1.13/server/d0caafb8438ebd206f99930cfaecfa6c9a13dca0/server.jar is the live one :slight_smile:


#9

I’m getting the same error as @montymint in my mineos.log:

{"level":"error","message":"[WEBUI] Server was unable to download file: https://s3.amazonaws.com/Minecraft.Download/versions/1.13/minecraft_server.1.13.jar","timestamp":"2018-07-18T23:27:49.255Z"}

Seems it’s grabbing from the wrong url.