Server stuck on "Starting minecraft server version 1.7.10"


Guys, i have an issue that i have no idea how to fix.
I start out by making a server then i download the FTB profile i would like, which in this case is Infinity(Have also tried DW20). Then i go run the and copy to live server directory, then i accept the EULA and press the start button and it looks like the server starts, even starts drawing on the machines memory, but in the log it just says:
“[13:25:29] [Server thread/INFO]: Starting minecraft server version 1.7.10”

As far as i can see its not a ownership issue… But my knowledge on the subject is limited.

Hope someone has an idea, sorry if its silly question, I’m pretty new to all this.

Right off the cuff, I’m imagining this has something to do with you cross-mounting the Minecraft servers directories. Customarily–and almost every deployment of MineOS–will have the servers locally mounted (and if necessary, the archives and backups symlinked remotely).

Anyway, I can’t tell immediately and with certain what the issue is, but perhaps the ownership permission is getting botched from starting the server.

You log in with mcserver, and MineOS tries to start the process with the mcserver user and grabs the UID/GID (199, in this case). And then when MineOS creates the process with 199 and starts writing, perhaps the mounted destination isn’t respecting it?

Is the 199 user your mcserver and is that mount remote or local?

Try all of Sir hexparrot’s instructions then you might want see below.

You can try using either FTBserver.jar to start your server.

In ‘profiles’ drop down choose a ‘FTBInfinity’ profile, then click ‘copy to live server directory’, then change the ‘runnable jar’ to ‘FTBServer-1.7.10-164.jar’.

Start the server. “Starting minecraft server version 1.7.10” is exactly what it should say and on ‘Server Status’ page it should say FTBInifinty under profile and Ping Version says 1.7.10.

When the ‘LatestLogs’ look similar to this:

[23:33:23] [Server thread/INFO]: Starting minecraft server version 1.7.10
[23:35:37] [Server thread/INFO]: Loading properties
[23:35:37] [Server thread/INFO]: Default game type: CREATIVE
[23:35:37] [Server thread/INFO]: Generating keypair
[23:35:38] [Server thread/INFO]: Starting Minecraft server on *:25565
[23:35:38] [Server thread/WARN]: The server will make no attempt to authenticate usernames. Beware.
[23:35:38] [Server thread/WARN]: While this makes the game possible to play without internet access, it also opens up the ability for hackers to connect with any username they choose.
[23:35:38] [Server thread/WARN]: To change this, set “online-mode” to “true” in the file.
[23:36:52] [Server thread/INFO]: Preparing level “world”
[23:36:56] [Server thread/INFO]: Preparing start region for level 0
[23:36:57] [Server thread/INFO]: Preparing spawn area: 1%
[23:36:58] [Server thread/INFO]: Preparing spawn area: 55%
[23:36:58] [Server thread/INFO]: Done (7.790s)! For help, type “help” or “?”

Log in with your FTB Client.

Good Luck!


Thanks for the response!

The 199 is mcserver, yes!
I have the jail and the data on two different drives, and just to make sure i ran chown for everything, so both the jail and the data drive were under 199:199 ownership. To no avail.

Honestly I’m not sure what you mean by local and remote!

I guess my question is: why is ls showing 199 and not mcserver?

That behavior to me is indicative that mcserver is not actually 199.

Hm… I have only logged in to MineOS web UI with the standerd mcserver login. the 199:199 is the original ownership of files created with mineos(When i download a profile or create a server), at least in my case.

and it says this in the server status tab.

1 Like