Server stops after a while

I’m pretty new to MineOS and I have set up a server on 1.17.1
my server starts fine and preforms good. after a while it shuts off the server sometimes a couple hours sometimes seconds or minutes. I suspect it to be java…

I see you are running av spigot style server with several plugins.

Your error report claims a java class lacks an method to do something, and in this error report it seems to do with something one rabbit entity tries to do.

There can be several causes for this error, but I suspect it may be a plugin that is not correctly upgraded for the version you are running.

Spigot comes from the older craftbukkit, and I ran some of those. when a plugin misbehaves you have to figure out what plugin is the misbehaving one. It might not be a bug that crops up in the plugin it self, but may be a bug that happens when two or more plugs tries to work together. This is time consuming!

So I would try the following:

  1. disable all plugins. (to eliminate an error in spigot it self)
  2. if a spigot without plugins runs nicely, try to enable each plugin by it self. This means spigot an only one plugin at a time. This does two things. It lets you discover what plugin is misbehaving, and it also lets you know if it is a composite error due to errors crashing with each other.

If a plug is revealed to be the sinner, disable that plug and re enable the rest. Then report the bug to the plugins developers.

  1. if all plugs work nice on their own. Try to enable each plug one at a time, until the error comes back. Then try the last plug in combination with each of the other plugs to figure out which two (or more) plugs it crash with. then report all plugs that cant work together to their respective developers. Then decide which of the crashing plugs you need the least and leave that disabled.
1 Like

Hi thank you very much for your respose!

I already tried running it as a vanilla server with the mojang .jar and no plugins. even without all this it still crashes (maybe even faster). i suspect it has to do with my java installation on the server because when I downloaded the game server folder over SFPT and ran it on my personal machine and it works flawless with all of the plugins enabled.

I can remember when I followed the guide on how to upgrade to new java the last command* didnt go trough and came back with an error…

*ln -s /opt/jdk-16.0.1/bin/java /usr/bin/java

Hi again.
Ah. A mismatch in java versions could also be a cause. Please try upgrading again (there is a post on this forum outlining how). Google or ask here if the error you experienced comes when you try upgrading and we’ll see what we can find out :slight_smile: