[Server] start failed (Error code: 1)


#1

Hello!

Whenever I try to start any servers with MineOS, it gives me this error. I gave the server directories permission 0777, so it isn’t a permissions error. The jar is present as well. No proxy log is made, but this excerpt is in the /var/log/mineos.log file.

Any ideas?


#2

We probably need more details to figure out the problem. A full log would be more helpful.

Also, you definitely do not want 777 permissions, so I’m inclined to think it is permissions, but just not R/W/X, but instead ownership. Can’t tell from the information provided, however.


#3

As root, I executed chown -R mc ./Bungeecord, but still receive the same error. Here is the entirety of my MineOS log (several months), though I’ve snipped my IP from it.

Should I remove the 777 permission?


#4

Alright, a few things:

  1. no, you needn’t change the 777, that shouldn’t have an impact (positive of negative) on how MineOS invokes the jar.

I see you’re using a very old version of Bungeecord, 1189, from 2016-09-23T00:08:20.772Z.

  1. Did this work before? Did it just stop working spontaneously or were you making other changes as root?
  2. Is an updated bungee cord going to work with your existing minecraft servers?
  3. You say you’re having trouble with starting any servers–so this isn’t specific to your bungeecord? Or are all your servers equally unstartable?

If you have any insight to what you might have changed, it might help here. history is the command you can execute as any user to see the list all of your previous commands. (you can share that with us or me directly in a direct message if you prefer).

  1. You did chown -R mc ./Bungeecord…where did you do this? Where is this Bungeecord directory located?

Lastly, and though likely not related, I see you’re using a version of the MIneOS webui from August 19, 2006. Have you tried updating your webui yet?