"server refused public-key signature despite accepting key" error SFTP

When trying to log in using an RSA keypair I get “the server refused public-key signature despite accepting key”.

Using winscp 5.7.5. I tried searching the internet and though it said it was a known bug and had solutions I need someone to tell me the solution in a ELI5 way please.

A couple of things to review.
Is the public key generated in ~/.ssh/ and assign the correct permissions as chmod 400 ~/.ssh/authorized_keys?
Have you at any point edited sshd_conf? - if you have restore the original.

If I were you I might delete /.ssh/authorized_keys and try following Will Dizon’s excellent YouTube tutorial

Yes the key is generated there and chmoded. No I didn’t edit the mentioned file. That is the video I used to set up the keys.

I also use winscp 5.7.5 but have not experienced your problem over many different distro’s and projects. I can say with a fair degree of certainty that it’s not a bug within winscp.

What is the servers OS? Ubuntu, MineOS Turnkey, and so on.

Make sure the servers up-to-date for instance Ubuntu would use sudo apt-get update and sudo apt-get upgrade

Take a screenshot and posted here as if you are going to generate RSA keypair with PuTTYgen so we can see the settings that you have selected.

I’m used the MineOS Turnkey nodeJS ISO. I have ran both “apt-get update and apt-get upgrade” and “apt-get dist-upgrade”.

I leave all setting at default on PuTTYgen as seen here:

Edit: it failed to upload pic so I posted it here on flickr

Edit 2: The first 2 results of this Google Search is people talking about the known bug in winscp.

You’re right those are the first two results and I noticed them first time I looked into your issue. The bug in the first search result has been resolved. Let’s settle this once and for all, try using a different client. FileZilla I recommend downloading the zip version so it’s portable and doesn’t have to be installed for testing.

If if you still receive the same error message with FileZilla. I would assume that something server-side. Taking the shotgun approach I would MineOS reimage your server and regenerate a RSA keypair.