Server Profiles failing to download


#1

I have installed the new mineos-node software on a freenas machine(used to run the old mineos and moved to vm on a linux server).

I would like to test out the beta server functionality(in the freenas previous version, i couldnt get 1.5_01 to work) and I notice the ability to upload custom jars is removed. I also see that you have an option to download the old betas but I always get a Download Failed 403 error, not only for beta/alpha builds but also some of the early full release builds.

In the past, Mojang didnt allow access tot eh beta versions so i counted on the ability to upload my own jars to mineos and since you cant actually download the old servers from mojang, what am I supposed to do for these older betas? Is there a way to upload them or will the download links be fixed or are these Jars not allowed at all and I should stick to the old mineos if I want to use a beta server?

Thanks for your help!


#2

Yes, simply connect to the server with SFTP and drop the file in your server’s directory, e.g., /var/games/minecraft/servers/myservername.

Then, in the webui, you select the jar file you uploaded under “runnable jar.”


#3

Thanks Hexparrot. This is kind of what I ended up doing except I already had it in that folder so I went to the profiles folder and uploaded my jar there to the corresponding version.

Now my issue is that I cant start any server that has an older jar(which works in my other mineos install). I will say, the new interface is slick and I like having all of the downloads readily available!

Ill futz around with it a little more and see what I can do. Any insight is greatly appreciated.

Thanks


#4

I’ve tried to SFTP my jars into the server directories, and I can’t get it to work. I believe the server is asking for root privileges, but when I try to sign in over SFTP, the server won’t accept anything but my standard user (mc). I’ve tried some different workarounds, like booting the server box from a Ubuntu Live CD wit the server’s hard drives in it, and then placing my Mac in Target Disk mode and transferring the files over FireWire to the server, but of course I didn’t have privileges. What should I do?

Edit: sorry about the thread bump

Edit: more info
I’m trying to download Forge 1.7.10 (build v10.13.4.1448) and I too am getting a download error.


#6

Hey Robert,

I’m also running mineos-node on a FreeNAS jail. I’m using a regular FreeNAS-ports jail and installing “from scratch” using the MineOS Wiki. I’m running FreeNAS 9.3-STABLE. Are you doing something similar, or are you running the MineOS Jail template? I’m having trouble creating new Minecraft servers and was wondering what you might be doing differently than me.

Thanks.


#7

Hi Ian,

I have the same freenas build but I was using the mineos plugin. The newest one is built of mineos-node. To be quite honest, I played around with for quite a bit and never got it running so I just went back to my virtual machine I have running on a different server. The fact that it’s so finicky to get working, especially for a jar I want to use that isn’t an automatic download is extremely off-putting.

I would recommend sticking with the old mineos build for the time being since it allows you to more easily upload your own jars.

Sorry I’m not much help, I wish I could help shed some light on your issue.