Server problems

Hey there, since my last post i have been searching around for solutions.
I have created a forge server on my own computer, checked if it ran (it did) and uploaded all the files to the server folder. Now it doesn’t work.
Server is on 1.18.2 Forge, using Java 17. In theory everything should be exactly the same, anything that might be different?

Well, i tried it and now it doesn’t seem like the server even tries to start. before I atleast got the server starting (although it did close a couple seconds later)
now it seems like pressing start doesn’t do anything. Anything you need to help me further?
I made sure to double check that i have java 17, I copied the universal jar and pasted the arguments in my file (removing the java in front and the “$@” in the back)

Try leaving the $@ at the end of the line?

didn’t fix it :confused: i’ve also tried leaving the java part in front, didn’t work either

If you navigate to the server dir in the command line can you execute

Huh, thats weird. i vividly remember all of them having that file but none of them do now, i’ll quickly make a new server and get back to you with what happens

well, i honestly have no clue what happend but suddenly it works so thats good i guess? does this mean i have to keep running the file manually via the terminal or can i now use the webui for that now that it presumably has set up all the files it needed?

You should be able to run it via the UI, if it’s all set up ok. MineOS wasn’t built to use non-jar files.
It should be a matter of getting the set up right.

As long as you’re using the correct user and permissions are correct I don’t see why it shouldn’t work.