Server names disappeared on dashboard


I have a created a jail with mineos on trueNAS 12. And everything worked fine, however after I created a mount in to the /var/games/minecraft folder there were no servers on my dashboard. When looking in the files the servers with all the files were there.
I am using a ‘_’ in the server name but that was never the problem before.

Any ideas what could be wrong?

Thanks in advance!

Try refreshing the server list, upper right corner where the user account is. You may also try updating the webui.

I tried refreshing it already but that doesn’t do anything. I will try if I can update the webui

I tried updating the webui, but this didn’t change anything.

After creating a new server It won’t show in the dashboard, but I can still enter it from the left menu. from here it shows the intalled profiles, but there are no runnable jars.

I’m wondering if the mount you created is redirecting the path. Where you trying to extend the path’s storage capacity?

I am not trying to expand storage capacity I am using it as a way of letting the files survive outside of the jail for when if I ever have to delete the jail the file will stay intact.

I tried creating an axtra user in mineOS the same one as the one I use on the other files with the same UID. somehow that seems to work.

Please check the following:

  • ownership of new mount-point
  • read-write rights in new mount-point
  • filessytem of new mount-point.

If the MineOS user do not have ownership or rights to the mountpoint, you will either get errors, or the server will not show up.

If the filesystem differs between MineOS and the mounted disk, (as windows mounted in a linux tree) you will have problems with special characters.

1 Like