Server ip not working?

so for some reason the server ip isnt forwarding me to the login screen. am i doing something wrong?

  1. is it working locally? (forwarding only applies when you are using a different internet connection than the server is using)

  2. are you sure the webui is up?

  3. does /var/log/mineos.log indicate any errors?

Lastly, what was your install method, MineOS Turnkey? Other?

@hexparrot i did everything in this video

Okay, well that doesn’t give me the necessary information to troubleshoot from questions #1, #2, or #3

@hexparrot ill switch on the server once again to see what it does

in “How to set up with wifi” you asked about how to set up WLAN on your server, as you do not have LAN available. Have you done this (set up wifi) or are you running on LAN?

i left the idea of using Wifi and actually found a ethernet cord long enough that will reach from my router to the computer after a few hours of posting that one (sorry it that one was a bit of a time waster i just needed to look around my house a bit to find one)

1 Like

@hexparrot ok so for odd reason the Ip works now when i put it in the address bar. but theres just one question i have left about this which password and username am i putting into the page the password that i typed upon installing the installing the server? or my username and password from this site
screen shot:

@Samurai_Toxic during the installation, you would have set two passwords, one for root, and one for mc.

Use root when installing system services, managing users, and updating MineOS with git.

Use mc when doing anything that involves running a Minecraft server, such as creating one, starting it up, modding it, etc.

While you are able to log into the webui as rootdon’t. You’d also receive a warning at the top of the page telling you to not.

@hexparrot that worked. now another problem is that im downloaded the MC version but im getting a slight problem while doing so

what do i need to actually do because im pretty new to this and have almost no idea what im doing for the most part i followed the instructions in a video i watched and made it a certain point where it wouldnt let me launch the server at all nor would it let it download versions. so i guess the proper question is how do i fix it

The first highlighted link there that says “Updating the Webui”, that post contains what caused it or why it doesn’t work and how to fix it (Updating the Webui).

1 Like

yeah i looked at the page but the thing is i dont actually understand what it i telling me to do

sudo su

[Enter your account’s password then hit enter]

cd /usr/games/minecraft

Wait for it to finish, then restart and you’ll be able to download/run 1.13.X servers.

1 Like

thank you. i will try this tomorrow when i start my server up

ok so i started my server up and as i should know login info is mc then w/e the password i set. but im not understanding what “sudo su” is suppose to mean or where i what i would do with “cd /usr/games/minecraft
/bin/bash” or maybe its something clearly there im not seeing dont get it

You need to be doing it from the system console/command line (typically physically via the machine itself unless you know how to use SSH for doing it remotely), not the web ui; you type those commands in and allow it to do it’s thing. How much do you know about Linux and/or command line?

how do i get to the console

[ALT]+[F1]” is one way if not “[CTRL]+[ALT]+[F1]