Running Overviewer on Turnkey

Description of the problem: Missing Texture Pack

What I have done

Make a backup copy of your current sources.list file
cp /etc/apt/sources.list /etc/apt/sources.list.bak

Append new line of text to current sources.list file

echo “deb ./” | tee -a /etc/apt/sources.list

Or could use GUI (Text Editor)

gedit /etc/apt/sources.list
Paste new line of text on new line at end of current sources.list text file in Text Editor.

Save and close sources.list

wget -O - | apt-key add -

apt-get update

apt-get install minecraft-overviewer

Running the Overviewer /var/games/minecraft/servers/Aarons_World/New+World /var/games/minecraft/servers/Aarons_World/mcmap

When I get to the point of running Overviewer I get a error about missing texture pack and it wants me to install a client or manually add files

You can transfer the client jar to the correct place manually, from a computer that does have the client, to your server. The correct places are:

For Linux: ~/.minecraft/versions//.jar

My problem is I can’t figure out how to install a client or where to create this folder since it keeps telling me I don’t have permission to do so on places I have tried

Basic Information about the environment:

Which distribution are you using? Turnkey
Have you updated the web-ui since experiencing this issue? No
Has this issue always existed or did it appear over time? Always
What steps can somebody do to reproduce this reliably? Install Overviewer 0.12

Where have you tried–what user were you attempting as?

What error did you get?

As far as what your primary concern is–does the error from Overviewer provide more concrete examples of what a texture pack is and where it is expecting it?

If you’re using MineOS Turnkey, you most certainly have access to putting files in ~/.minecraft, as the base is your $HOME directory, a place where you have ultimate permissions.

Attaining the client from the launcher doesn’t seem appropriate, as that is something you’d do on a client machine–not a server machine with no monitor, but it should still be possible to get the client on the server itself. From the command line, logged in as the mc user, are you not able to wget the client jar?

You can copy/paste your actual terminal output and we can figure it out, from the information it’d provide, e.g., what user you are, what error you’re getting, and what your file locations are.

I installed Overviewer as root.Then I when I run it as root at a command line on the server. I get a warning I should not be running as root, and can find path of texture pack, which is the Minecraft texture pack that the Minecraft client uses to display the blocks while you play. As mc I ran wget the client.jar and now I get a error so long I took photo to make sure I didn’t make a mistake coping it. since

I couldn’t see the .Microsoft folder I didn’t realize it was there

Permission denied means you likely tried running the command to render overviewer maps as root, and as a result, created files in the /var/games/minecraft/... server directory owned by root:root (and thus, not writable with mc).

Just like if how you created a file owned by root:root in /home/mcmc wouldn’t be able to do it and would get Errno 13.

To restore permissions, execute this as root:

chown -R mc:mc /var/games/minecraft