Restoring rdiff backups not working

I have been using MineOS since late last year, and had set up rdiff backups fine using this command

0 */5 * * * *

This saves a restore point every 5 mins, which worked fine.

However, I haven’t used MineOS in a couple of months, and have created a new server this week, and applied the same cron job to this server.

The server is backing up the files fine, and I can see all the increments are there. All permissions are set correctly for both the backups and the server files, to my main user (1001).

However when trying to restore it simply won’t restore any of the backups.

I even tried running the command manually but no dice.

Now what I have noticed is that the naming convention of the rdiffs has changed since it previously worked, and I have moved to british summertime since so not sure if that’s been the cause?

old file that worked (pre BST);


new file that doesn’t restore


Note where there was a Z before it is now +01:00. It’s the only difference I can surmise between the two?

If this is the issue how do I get the restore points working again?

Have you tried to remove the time zone modifier and replaced it with Z?
How about setting the locale time zone to the old location. Does it work then?
What erro messages do you get?