Restore Points FAIL? Completely stock installation

Hello. I just installed a fresh copy of MineOS via TrueNAS 13.1 (freebsd) from the plugins section. When I create a server from within MineOS (not importing, just clicking “create server”, and then try clicking “Create restore point”, it fails with the message " Uh oh!! Restore point attempt failed a few seconds ago." To my knowledge, there is no reason this should be happening.

Before anybody asks, here’s more info:

  • the plugin/iocage/installation is totally unmodified
  • there is no persistent storage or added “mount points”.
  • I’ve changed nothing at all with packages, shell commands, permissions, or folders.
  • the only thing I’ve done is install the plugin, and log in. Just as I’ve always done in the past with MineOS.

I’d like to know what I can do to fix this quickly because this has never happened before on past versions of MineOS. It’s suddenly happening now.

UPDATE: I’ve solved the problem. Check message below.

TrueNAS 13.0 U3.1
MineOS install method was “plugins” section of TrueNAS UI

SOLVED: rdiff-backup was missing module “yaml”.

To get yaml module, I needed to have “pip”. Which wasn’t included for some reason. I entered the FreeBSD jail shell and begun with the commands below.

To install pip, I did the command:
python -m ensurepip --upgrade

After installation, I did this command to install “yaml” :

python3.9 -m pip install pyyaml

After doing these steps, this problem was solved. MineOS now makes backups properly in the webui (as it’s supposed to). I think this means that the issue is related to the packager of MineOS in the TrueNas repo, and not MineOS itself? I’d love to report this bug, but where do I do this exactly?

UPDATE: I reported this issue to github

1 Like

I see you found your way but just for reference i don’t think Truenas MineOS plugin is official and is managed by other people.

Truenas often does not get much help here. People here tend to use MineOS on bare metal or on more traditional style hypervisors.

You would be better off asking these things in the future over at Truenas’s community as you will probably get better information.