Restore points and archives not running automatically

I have been having issues with the cronjobs to keep running longer then a few days. right now I’m not able to get then to run anymore. In past I was able to change time on when I wanted the backup to be made via WebUI and it gave it time to make a new one then changed back to my desired times I wanted and it would work again, but it has been a few days since I have not been able to get to run. I can manually make Restore points and archives.

What does the MineOS log report? /var/log/mineos.log

this is the last error in my logs, there are many errors never looked at this log before, about a week ago I needed to install openjavajdk-jdk and then it told me I needed remove a java I didn’t need anymore is this my problem?

[17/Dec/2014:00:30:06] ENGINE Error in background task thread function <bound method cron.check_interval of <main.cron object at 0x2afb150>>.
Traceback (most recent call last):
File “/usr/lib/python2.7/dist-packages/cherrypy/process/”, line 475, in run
self.function(*self.args, **self.kwargs)
File “/usr/games/minecraft/”, line 25, in check_interval
getattr(mc(i, path_owner(path_), self.base_directory), action)()
File “/usr/games/minecraft/”, line 43, in wrapper
fn(self, *args, **kwargs)
File “/usr/games/minecraft/”, line 375, in backup
self._command_direct(self.command_backup, self.env[‘cwd’])
File “/usr/games/minecraft/”, line 630, in _command_direct
preexec_fn=self._demote(self.owner.pw_uid, self.owner.pw_gid))
File “/usr/lib/python2.7/”, line 544, in check_output
raise CalledProcessError(retcode, cmd, output=output)
CalledProcessError: Command ‘[’/usr/bin/nice’, ‘-n’, ‘10’, ‘/usr/bin/rdiff-backup’, ‘/var/games/minecraft/servers/Aarons_World/’, ‘/var/games/minecraft/backup/Aarons_World’]’ returned non-zero exit status 1

One of the most common reasons for rdiff-backup's “returned non-zero exit status 1” is botched permissions.

The most common cause of permissions issues is things being owned by root, after doing various command-line things.

Here’s how we can see the error directly:

root@core games/minecraft# ./ -s servername command_backup
'/usr/bin/nice -n 10 /usr/bin/rdiff-backup /var/games/minecraft/servers/servername/ /var/games/minecraft/backup/servername'
root@core games/minecraft# su - mc
mc@core ~$ /usr/bin/nice -n 10 /usr/bin/rdiff-backup /var/games/minecraft/servers/servername/ /var/games/minecraft/backup/servername
mc@core ~$

For me, since all is well, it goes right to the next command line prompt. For you, it should instead spit out the error that rdiff-backup is experiencing (but not reporting).

Alternatively, you may just go right to /var/games/minecraft/servers/servername and do a check of the permissions using ls; whichever you feel most comfy with.

Also, I did this on a test MineOS Turnkey installation. If you’re using a user other than mc, be sure to substitute that in.

If it is permissions, the answer probably is:

chown -R mc:mc /var/games/minecraft/backup/servername/

those two folders are owned by mc I ran the chown line just incase

Getting this error now, and still not doing auto backup.

[17/Dec/2014:23:34:11] ENGINE Error in HTTPServer.tick
Traceback (most recent call last):
File “/usr/lib/python2.7/dist-packages/cherrypy/wsgiserver/”, line 1837, in start
File “/usr/lib/python2.7/dist-packages/cherrypy/wsgiserver/”, line 1902, in tick
s, ssl_env = self.ssl_adapter.wrap(s)
File “/usr/lib/python2.7/dist-packages/cherrypy/wsgiserver/”, line 52, in wrap
keyfile=self.private_key, ssl_version=ssl.PROTOCOL_SSLv23)
File “/usr/lib/python2.7/”, line 381, in wrap_socket
File “/usr/lib/python2.7/”, line 143, in init
File “/usr/lib/python2.7/”, line 305, in do_handshake
SSLError: _ssl.c:489: The handshake operation timed out

Unrelated error. Did you try running the backup manually via that command I posted?

yes the backup runs, it also tells me chat it is running. It didn’t tell me in chat is was disabling level saving and enabled level savings before but it does not run via conjob.

When possible, try to provide a copy paste from PuTTY of what you’ve done, as it helps give me a better picture of what you’re doing. Yes, the backup ran…do you run it as root? As ‘mc’? What was the command you ran–did you adjust it for Aarons_World or leave it at “servername”?

Was the server running at the time?–did it mimic the conditions that would occur during the scheduled backup?

I run backup from WebUI I believe I am logged in as “mc”, yes the server was running at the time. When I adjusted chown it was for Aaron’s_World this that’s the only one I’m running at the moment, the other one is a testing world to see if plugins work.

Have you tried restarting your host server at any point?

Really, the only way to fix this is to be able to reliably reproduce what MineOS is doing, scheduled–which is that command. If that command isn’t invoking the error (as you’ve said), it could be a one-off, runtime who-knows-why kind of issue.

Try restarting the whole host during some downtime and see if that changes anything.

Also, be clear about what commands you have executed to us. At this point, you’ve said you’ve run the chown, but we simply have to take your word for it, but may be continuing on false pretenses that it went correctly.

I have rebooted the host server 37 hours ago, I don’t know any other way to run the backup but via WebUI, I would be willing to try other commands if I knew some. This worked fine until about 4 days ago. About the same time I know I ran “hwclock --localtime -s” just not sure if it was before or after the backups stopped.

when I got home and rebooted the server the Restore points started to run automatically. I will turn on the archives again and let it run to see if it fix. Now that other error I have not see it with same line errors, how would i fix this error. After reading threw the error completely I noticed it looks like it might be cause=d cause of second network card on my server I’m not using.

[18/Dec/2014:22:41:21] ENGINE Error in ‘start’ listener <bound method Server.start of <cherrypy._cpserver.Server object at 0x15a6b10>>
Traceback (most recent call last):
File “/usr/lib/python2.7/dist-packages/cherrypy/process/”, line 197, in publish
output.append(listener(*args, **kwargs))
File “/usr/lib/python2.7/dist-packages/cherrypy/”, line 151, in start
File “/usr/lib/python2.7/dist-packages/cherrypy/process/”, line 167, in start
File “/usr/lib/python2.7/dist-packages/cherrypy/process/”, line 410, in wait_for_free_port
raise IOError(“Port %r not free on %r” % (port, host))
IOError: Port 8080 not free on ‘’

[18/Dec/2014:22:41:21] ENGINE Shutting down due to error in start listener:
Traceback (most recent call last):
File “/usr/lib/python2.7/dist-packages/cherrypy/process/”, line 235, in start
File “/usr/lib/python2.7/dist-packages/cherrypy/process/”, line 215, in publish
raise exc
ChannelFailures: IOError(“Port 8080 not free on ‘’”,)