Reboot causing MineOS to not function correctly


Upon fresh install of MineOS atop Ubuntu server 21 everything works fine. I can connect to the webui, create a server, and join that server to play. However, when I power cycle my raspberry pi I can no loner connect to my Minecraft server in game. I can access the webui, but when I log in to the webui I cannot see my server anymore and there is no commit listed in the top right dropdown. Additionally, the download profile page shows " No Profiles Are Available; Check Internet Connectivity And Refresh The Profile List. "

I have checked the mineos.log file and found this error repeating:

{“date”:“Wed May 05 2021 15:24:13 GMT+0000 (Coordinated Universal Time)”,“process”:{“pid”:8010,“uid”:0,“gid”:0,“cwd”:"/usr/games/minecraft",“execPath”:"/usr/bin/node",“version”:“v12.21.0”,“argv”:["/usr/bin/node","/usr/games/minecraft/webui.js"],“memoryUsage”:{“rss”:62828544,“heapTotal”:29450240,“heapUsed”:18967080,“external”:2256383,“arrayBuffers”:776443}},“os”:{“loadavg”:[0.85,0.99,0.69],“uptime”:775},“trace”:[{“column”:16,“file”:“net.js”,“function”:“Server.setupListenHandle [as _listen2]”,“line”:1310,“method”:“setupListenHandle [as _listen2]”,“native”:false},{“column”:12,“file”:“net.js”,“function”:“listenInCluster”,“line”:1358,“method”:null,“native”:false},{“column”:7,“file”:“net.js”,“function”:“doListen”,“line”:1495,“method”:null,“native”:false},{“column”:21,“file”:“internal/process/task_queues.js”,“function”:“processTicksAndRejections”,“line”:85,“method”:null,“native”:false}],“stack”:[“Error: listen EADDRINUSE: address already in use”," at Server.setupListenHandle [as _listen2] (net.js:1310:16)"," at listenInCluster (net.js:1358:12)"," at doListen (net.js:1495:7)"," at processTicksAndRejections (internal/process/task_queues.js:85:21)"],“level”:“error”,“message”:“uncaughtException: listen EADDRINUSE: address already in use”,“timestamp”:“2021-05-05T15:24:13.369Z”}

NOTE: I changed the port from 8443 to 443 just to see if that would help. Same error either way.

I have tried killing the node process at that port and restarting, but no luck.
I have also checked the server config file for issues (assigned IP is

The only solution is to manually reinstall the Minecraft server EVERY time I reboot my machine, which renders MineOS useless.

Thanks for any help you can provide.

This seems like a network issue.
Please check that your Pi still has network. An easy way to do that is to type the following command in a shell:


ip add show

The first command checks if your Pi can reach external adresses
The secon lists your pi’s current network config and adresses.

Please check that it has a valid IP, correct DNS and Gateway.

Hi iMelsom,

Thanks for the reply, this issue is proving tricky.

Network connectivity is good. I can ping websites and get a valid response. The Pi is connected via ethernet and I am able to ssh into it no problem.

here is the ip add show output:

2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000

ip address is valid (connected via ssh anyways…)

Like I said, when I first installed mineos it worked fine and I could even connect other players outside of my LAN.

It is only upon restart when errors occur.

Have you tried to set a different IP address? Because one line has messaged
[“Error: listen EADDRINUSE: address already in use”," at Server.setupListenHandle [as _listen2] (net.js:1310:16)"

Also, what values do you have for the heap XMS and XMX?

Setting the ip to just means that it listens to all available interfaces, which is what we want.

As you can access the pi with ssh, it seems ut at least has network connection and local adress. your ip add show do not show any of the following:

  • ip adress
  • DNS-adress
  • Gateway-adress.
    But I suspect you snipped out those parts fearing hacking. LAN adresses are taken from a shared common pool, and only available for you on your local area network. This is why we need services like portforwardint and NAT (Network adress translation) to conenct from LAN to the Internet. You can in other words safely share your servers LAN adress, unless it is connected directly to the internet.

We can assume it has an IP-adress (else SSH and putty from another LAN connected computer would not work).

Please check that DNS and Gateway works. This is why I reccomended trying a ping to a known server on the internet. If ping fails try another adress to verify (it could be that the server you tried blocks ping attempts). if all ping attempts from your server fails, you have a problem either with DNS or your server do not know the adress of your gateway.
To get the final two you also need the following commands:
ip r

systemd-resolve --status | grep Current

But it sees you are not the only one having problems with Pi and networking after reboots: Pi looses internet connection after rebot - Google Search

The Pi is directly connected to the internet as I connect to it from outside of my home network regularly, to my knowledge only my public ip is really sensitive, which you cannot see in the output of ip addr show, but I like to be cautious. I will display the ping statistics anyways: ping statistics —
6 packets transmitted, 6 received, 0% packet loss, time 5008ms
rtt min/avg/max/mdev = 13.923/14.290/15.506/0.567 ms

There is no issue with connectivity to the internet on the Pi’s behalf. To be doubly sure, I also tested with cURL and WGET, both of which return results from the internet correctly. Furthermore I can and ssh into the pi from outside my home network. Regardless of how many times I reboot it, I am always able to access it from the internet and connect to websites, update, etc…

systemd-resolve --status | grep Current:

Current Scopes: DNS Current DNS Server: Current Scopes: none

and including the list of DNS servers, since I modified this (only modified after it stopped working)

Current DNS Server: DNS Servers:

This is almost certainly an issue with MineOS, either with the software or, more likely, my configuration of it.

Could changing the current DNS to google’s help? I am going to try and mess around with the DNS settings and see if that helps. But, it was working initially so it seems like some configuration changes or some file gets created/deleted upon reboot, I’m guessing.

Thanks again for your help… Really pulling my hair out with this one.

I would also like to note that deleting /usr/games/minecraft and then installing MineOS again fixes the problem however I have to do that everytime I reboot my raspberry pi… I wrote a script to do that upon every startup however this is really just a bandaid for the real issue.

How would I check these values (XMS and XMX)?

These are in the world server for the Java settings.

Ah yes, well I can’t even access the server after reboot. It would be set to the default settings.