Rdiff & Python, 100% CPU Usage and no server start

Greetings! Using MineOS Turnkey.

I recently pre-generated a world to reduce lag on my server and I aimed for a 5GB big world folder. I now have it and when I put it on the MineOS server I have rdiff goes crazy. After having it working all night it finally finished and I now have a 10GB big rdiff “starting point”. But now whenever I try to start the server (server won’t start, btw) or even enter the page for the server nothing happens. I check the server usage by using the “top” command and I see rdiff hogging 100% CPU. After a few minutes it goes over to Python using 100% CPU. After this, the server page on the loads the details. Such as GB size of the backup and the contents of server.properties. If I press Start Server the whole process repeats again but the server never starts.

I have tried to rename the world map but that didn’t help at all. It seems like some process is not used to handling big folders.
I’d love to help cleaning this bug out!

The only interesting thing in the logs I can find is the following:

Edit: I’ve tried re-installing the entire operating system but that didn’t help, sadly.

I’m very embarrassed that this went on unattended for so long!

I’m not sure if you have somehow resolved it or are still expecting to, but I’d be interested in seeing what caused this.

Based on your description, it seems like a file-system level thing rather than a web-ui thing, what with 5gb of pregenerated worlds being quite a bit to make a mirror of via rdiff-backup (which is written in python).

The error you got in the screenshot, however, would be related to the scripts and likely the server jar itself: UnicodeDecodeError might mean something it gets returned from attempted pings, but to explore that I’d need to know what server jar you attempted to start (that never started).

If you’re still interested in figuring this out, I’d be happy to help out. Let me know!

Hey Hexparrot! Thanks for answering.

First, I’d like to give you an apology for the late response. I’ve been a bit busy.

Second, I am at a total loss at how to solve this and I was unable to find anything in the logs.
I am willing to give you full SSH access through Teamviewer or something similar. Would you be interested?
I could also RAR the whole minecraft folder and send it your way. It’d be a few gigabytes though, but I have no problem uploading it since I have quite a hefty upload speed. Basically, whatever would be the easiest way for me to help you solve it. I figure this could be quite a problem if MineOS ever gets adopted by a bigger Minecraft hoster.

About the screenshot, I now believe this might be unrelated or as you said, the ping as it thinks the server is up when it is actually down.

The Minecraft I used was 1.7.2, with the FTB: Infinity modpack. I haven’t been toying with it for a while though, so I’ll check again if the problem still exists as soon as I have time tomorrow. If it doesn’t happen anymore we won’t have to look into it, after all.

Edit: On a second thought, RARing the folder might be the easiest due to timezones and whatnot. :smile: