Question about installing htop


#1

Okay, I was trying to put something in to monitor the processes because I though something fishy was going on with the processes doing a restart (start.sh) script.

apt-get install htop

Now, the webUI is acting kinda goofy… did HTOP overtake something in the system to prevent a non-root members webui not to be able to interract with the server now? I get to the screen after login showing Servers online 0 yadda yadda… but theres no server in the listing at the bottom now and it seems frozen.
It also makes me re-enter the credentials for a login after I refresh the page as if it completely forgot I was logged in.

Edit: It should also be noted that the server itself is running. I can get into it through the client just fine.

Edit2: Also should be noted that now if I log into webui as root it shows the monitor progress just fine. No servers in the list though. I can also refresh and it doesn’t ‘forget’ I was logged in.

Is there some way for me to fix this issue? Maybe it’s a simple permissions thing I need to play with? Or just back up the server and reinstall because, well, I dun goofed. #tfs /snicker


#2

Wasn’t htop at all it seems.
It appears it was DynMap plugin. :confused:


#3

I see a lot of DynMap related issues pass through here. I for my part ditched the entire DynMap path and went the Minecraft Overviewer way. https://overviewer.org/

My windows machine runst dynmap at a schedule reading from the server directories I want on the MineOS machine, writing to a folder on my webserver. The three are separate (more or less, considering one is the virtual host, and the two other are virtual machines running on the host). This means that all map files for a web-map of our world are kept separate from MineOS, and do not interfere with MineOS ability to parse and read folders, or bulk up the archives and backups in MineOS.

The downside to this is of course that I do not get live update of the map. The map only updates when overviewer has done it’s job. Since it is pretty resource intensive, I only do this once a night. I run marker (signs and players) updates once an hour though.


#4

I dig it. I actually dumped it and tried to run it under MySQL without success (still wet behind the ears) although using SQLlite worked fine. Seems to be running a bit faster too so there’s that. I considered overviewer also but decided I really didn’t want to lol