Python to JavaScript - Can't start any Servers [Startup Error 1]


#1

I recently switched machines to do a complete clear of my old distro which had MineOS Python installed on it. I installed Debian (9, I think), and did the .JS iso install. I manually updated to Java 8, as some plugins require this. Upon uploading all of my documents (I did this with scp transfer in command line) I set their group ownership to minecraft:minecraft. (https://gyazo.com/05803f01539d7dbe2e3f6c2db06ecc7a) [Test and Test2 were created in this version of MineOS]

I am now getting the Startup Error 1, on any profile. It does not seem to be dependent on the profile at all. I’ve done many full machine restarts, and am nearing my wits end. Please help me understand what I am doing wrong so I can get my server back online.

My MineOS Log: https://pastebin.com/vvK8rNxP

My biggest concern right now is that for some reason I wouldn’t be able to merge from a Python based server to the more elite and well maintained Java Script server.


#2

Well we have a few things to unpack here.

First, a few hundred instances of this:

{“date”:“Tue Nov 07 2017 00:55:21 GMT-0500 (EST)”,“process”:{“pid”:2704,“uid”:0,“gid”:0,“cwd”:"/usr/games/minecraft",“execPath”:"/usr/bin/node",“version”:“v4.8.5”,“argv”:["/usr/bin/node","/usr/games/minecraft/webui.js"],“memoryUsage”:{“rss”:349188096,“heapTotal”:125836032,“heapUsed”:88417712,“external”:466311}},“os”:{“loadavg”:[0.02490234375,0.14501953125,0.08251953125],“uptime”:305},“trace”:[{“column”:7,“file”:"/usr/games/minecraft/node_modules/fireworm/lib/file.js",“function”:null,“line”:45,“method”:null,“native”:false},{“column”:15,“file”:“fs.js”,“function”:“FSReqWrap.oncomplete”,“line”:82,“method”:“oncomplete”,“native”:false}],“stack”:[“AssertionError: File should always be initialied with stat”," at /usr/games/minecraft/node_modules/fireworm/lib/file.js:45:7"," at FSReqWrap.oncomplete (fs.js:82:15)"],“level”:“error”,“message”:“uncaughtException: File should always be initialied with stat”,“timestamp”:“2017-11-07T05:55:21.343Z”}

Based on the frequency of it appearing, I’m guessing Fireworm is having a hard time with a number of files within your server directory. I’m wondering if it’s having issues with symlinks or hardlinks–either of which could just be filling the logs with false flags. At any rate, I think it’s unrelated to your big issue:

Start (and subsequently Kill) commands don’t seem to do anything.

I’m guessing then that all the servers are using Java-based profiles. If so, this might indicate that an issue with the Java 8 manual install didn’t go well. Can you confirm Java works well from the command line, java --version? And even more importantly which java points to your 8?

That’s my initial thought, at any rate. Because vanilla 1.12.1 requires Java 8 (as you know) and if Linux is still using the old Java (because it’s the first java binary in root's PATH) then that would explain it not working.

And if the building of a spigot depend on 8, then that would explain ‘all profiles not working’.

Your screenshot only shows one profile, though. If you test 1.11, see if it runs. If it does, it’s likely that MineOS is not using your new install. You can check as root with which java.


#3

When I do ‘java -version’ I get the following:

java -version “1.8.0_151”
Java ™ SE Runtime Enviornment (build 1.8.0_151-b12)
Java HotSpot ™ 64-Bit Server VM (build 25.151-b12, mixed mode)

When I do ‘which java’ I get the following:

/usr/bin/java

Another issue I noticed is indeterminately not being able to write to the file, I’m not sure this is something that could be related or not, or if you know the direct fix. I know it’s a chmod issue, but no idea what command to execute.

I tried creating a 1.11 server, but on start it gave the same exact error.

EDIT:
This is not a java issue, I ran a server via ssh and it started fine. This is a MineOS related issue and I suspect permissions.

EDIT 2:
I have managed to fix all of these issues by reinstalling my OS (was Debian 7) into a Debian 9 server.