Putty connection unexpectedly closed


#1

Hello,

I’ve been attempting to connect to MineOS with Putty and am instantly receiving the ‘Server unexpectedly closed network connection’ fatal error after clicking open in the putty config dialog. Here is some info on my setup:

  • MineOS is running through an Unraid docker. Internal IP is 192.168.0.100:8443 which works great on the webUI. No access issues there. I am able to start up a vanilla server using the webUI just fine and connect to it with a client.

  • The Unraid docker has two ports for MineOS, mine are 8443 and 25565. Attempting to use Putty to connect with 8443 provides the unexpectedly closed error, and connecting with 25565 provides a connection refused error. I don’t typically use Putty, it has not been configured differently than what is default when you download it.

  • I attempted this same tactic with WinSCP to see the same unexpectedly closed error.

It seems like I am following normal procedure to connect to the MineOS after reading some how-to’s because the guides all assume this connection sets you right on the login prompt without issues. Any ideas what I may be missing here?


#2

Neither 8443 or 25565 are SSH (putty) ports. 8443 is an HTTPS port (web browser) and 25565 is your Minecraft server.

Putty would connect on the SSH port, which is 22 by default.


#3

Thanks for the reply hex,

Using port 22 opens a login prompt, but it is connecting to the Unraid. I can log in here with my root user info for Unraid which responds with a distro version and a root@tower:~# prompt. MineOS login info does not work here. I was afraid there might have been a conflict and I think that confirms. Can I change something in the mineos config to alleviate this?


#4

From the unraid terminal (root@tower:~#), couldn’t you then SSH to 192.168.0.100?

root@tower:~# ssh mc@192.168.0.100

#5

Thanks again Hex, never thought to SSH from within the Unraid terminal. I’m quite new to this.

Using the command like you suggested is continually prompting an incorrect password. I’ve found on the forums here the most common login is mc:mc, however my webUI uses minecraft:minecraft. Either way both reply with the same error and combinations of both have the same result.

Thinking that I might be stuck still trying to get past Unraid, I went ahead and used the unraid login info a second time and it goes straight to the distro version response with root@tower again. Maybe I should look to disable the Unraid SSH somehow temporarily while trying to work with mineOS.