Pruning Error for Backups

I am finally getting around to cleaning up our Restore Points after way too long and we are stumped on what is happening when following information from here:

I followed the MineOS way and it presented this error:

/usr/games/minecraft$ ./ prune contingency 1M
Traceback (most recent call last):
  File "./", line 161, in <module>
    retval = getattr(mc, args.cmd)(*arguments)
TypeError: unbound method prune() must be called with mc instance as first argument (got str instance instead)

I have 0 clue where to go from there and my buddy who understands this a bit better says it makes sense when looking into the .py file, but we don’t exactly get where we are supposed to define the instance? (If that makes no sense, sorry, I don’t entirely understand what was meant by this…)

I then tried the rdiff-backup method and relatively confused by this. It says for a dir to use ‘/home/mc/servers/pvpone’. Now our directory is in ‘/var/games/minecraft/servers/TARGET’ and I tried this. It returned:

-bash: rdiffbackup: command not found

I tried adjusting to target ‘/var/games/minecraft/backup/TARGET’ and it returned the same information. So currently I am not entirely sure what to do to prune my backups efficiently. All of this was done under ‘mc’ account.

Any help greatly appreciated!!

i apologize that some of the wiki pages are old…written for an older version of Mineos scripts no longer available or in use.

The most efficient way to prune now is to use the webui–under restore points, use the guided drop down box to choose a date for which all older restore points can be pruned.

Safest and most straightforward way. Pardon the short reply–I’m on my phone. Let me know if you have any further questions.

I feel very stupid for not even SEEING that option… Thank you. :smiley: