Problems with a New Spigot world

Hello again…

I am having trouble getting spigot to run properly and I could use your help/expertise.
Long story short… I loaded up a new world in the WebUI, and I followed the instructions for the Build-latest & Copy files to server. I get an error even when the server has no Plugins installed.

Steps I have taken to replicate error

-Stop any other server on the system from running
-Reboot the entire host machine
-Confirm all servers are stopped
-Load new Vanilla world (1.19.1) & let the world propagate
-login & log off (to see the world has populated)
-shut down server
-In WebUI navigate to Spigot Tab
- Download latest builds
- Build 1.19.1 (spigot)
- Copy files to server using WebUI button and selected the fresh world I just made

  • Boot up world
  • Login to see F3 shows spigot (it did) & log off
    (Here is where the problem started)
  • I stop the server with Button in WebUI
  • Watch latest.log (console) to watch the shutdown process
  • Get Error

As the error is being output to the console it stops reporting and says
“” The server has been generating logs beyond the rate-limit threshold. Log tailing has stopped and can be re-enabled by refreshing the webui. “”

I can post the whole .log / crash file if that would help.

There are NO Plugins Installed on the system yet. I would start putting them in after the shutdown, if it had worked properly.

I don’t read Error Message and the error says “This is (probably) not a spigot bug”

Any info would be greatly appreciated. I also have a second problem regarding RAM but I can make a new topic once this first error can get smoothed out.

Thanks for Reading

yes. There is no point submitting half a log.

Again… I don’t speak Error Message so I was unsure. Only 19 lines were missing

Thank you

Sorry for the late replay, Life.

I don’t think there is anything wrong when looking at the log tbh . In fact i think the spigot server is doing exactly what it is supposed or designed to do. I will break it down for you.

[17:22:57] [Async Chat Thread - #0/INFO]: <[PlayerName]> typing /stop

[17:23:00] [Server thread/INFO]: [PlayerName] issued server command: /stop

[17:23:00] [Server thread/INFO]: [[PlayerName]: Stopping the server

[17:24:03] [Spigot Watchdog Thread/ERROR]: The server has stopped responding! This is (probably) not a Spigot bug.

Basically i would say that the watchdog is literally Erroring out because the server stopped which means the server stopped responding which in tuen the watchdog thinks something happened its all just a red herring.

if you look at the start of the log and at the end of the log you world looks like it is both shutting down and saving properly so if everything else on your server is functioning correctly like when you play it etc then i would not be to concerned.

I would look at increasing the timeout-time setting in the spigot settings file.

Default: 60
Type: Integer
Description: How long - in seconds - the server should go unresponsive before performing a thread dump in the console and, if configured, attempt to shut down and restart.

time how long it takes for your server to shutdown fully and and a few seconds on top of that like 20 seconds or something. This can be your timeout interval.

Ok that makes some sense, since there are no plugins installed I was at my wits end for why it showed an error at all.

The usual restarts were every 12 hours via Crontab and the WebUI would say
“Restart Failed” = True. Then after a few more minutes it would (sometimes) complete the shutdown and save properly.

Thank you… Ill try what you said and report back later.

Ok, I can’t believe it was that simple.

I did exactly what you said and changed that timeout-time. And that fixed the Watchdog-Thread Error and the Crontab-restart malfunctions.

I don’t know how you do it but Bravo.

I made sure it worked on the test-world, then tried it on the main world (the one that will be used actively) and after yesterday and today its purring like a kitten day and night.

I had to divvy up the restarts into a stop, wait 3 mins, and then start again… to give it enough time to save everything. The delay for saving must have been too long for the reset command, that’s why I kept getting “restart failed = true” and yet at the end of the log file still says the machine saved properly.

Almost 2 days running straight now and the (now only once) daily resets are going off without any problems. The other RAM problem I had I figured out by myself, and the system is handling everything great. Even with the small number of friends I have logging in… the server log doesn’t say “can’t keep up” or have any issues lagging / crashing.

Ank, You’re amazing idk how you got it perfect from just the " The server has stopped responding!" prompt.

Much Much Thanks for keeping this boat sailing on smooth waters :smiley:

Can a Higher-Up mark this post as [Solved] / [Closed] ? Thanks Again!

1 Like

Well it could look like something is wrong but if you can see the signs then its obvious.

Because you typed /stop and then the server started erroring straight away it kind of led to that line of thinking. So what i did was looked up spigot to find more about its watchdog timer because i am not to familiar with spigot i have not used it much and for a long time either but i saw it has a timer set to 60s by default.

if you look at the log it matches your time stamps exactly, basically you stop the server and then 1 minute later it errors. Even just the fact you stopped the server and then it errors is a pretty good sign because a watchdog is monitoring something that is live not dead.