Problem with the installation of forges

I want to install forge version 1.11.2.
When I run the server (accept EULA and start), the server starts and crashes 20s later.
In addition I have no logs or console that opens!
I specify that I have tried with the vanilla versions and everything works.

Are there any errors in the mineos.log file when it crashes?

Which MineOS distro are you using? If you are using Jessie, or other older version, then I suggest upgrading. You might be running on an outdated nodejs.

Good evening, please excuse my rudeness to your help. I succeeded in having my forge groomed. I am using the nodejs version of mineos on a dedicated pc (a very small server). Mineos is installed on an ssd and everything works perfectly! The only problem is when I want to add mods, plugins, maps or servers. When I connect in sftp (I am using filezila), I am sure that it is ( I use mineos with the root account, either on the web interface or on the sftp. I also tried with the mc account but nothing changes except access to less folder. I tried to search the forum but my sftp files do not look like those of other users! Do you have a solution? Thank you !

ps: I apologize once again for my rudeness!


Well first off, no apologies are needed.
Secondly, in other posts I’ve read, logging in as root breaks things apparently by changing the permissions. I would use mc and add that account to sudo if you need elevated permissions.
Thirdly, you need to navigate to /var/games/minecraft/... In there you can find the similar directory structure as you may have seen.

For clarity, logging in as root doesn’t as much “break” things as it makes things owned by root, which you can see would keep any non-root user from doing things to those files and processes.

When things are owned by some other user, e.g., mc or will or what have you, root otherwise can still just impersonate that user and run the process/manage the files.

But when owned by root, it’s working via root and by nobody else.

Hello, I solved my problem but again thank you for your help. I used winscp instead of filezilla and the problem is resolved. WinScp shows me the “normal” files and I have access to them while logging in with the root account. Thank you again for your precious help !