Port Forwarding with DS-Lite

#1

Hey everyone,

I dont know what to do anymore, my problem is that no matter what i do, noone can connect to my MineOS server besides me, of course.
Here’s a screenshot of my iptables config:

I tried to iptables -F and then iptables -P INPUT ACCEPT and added a UDP Protocol for 25565 aswell

My Router (FRITZ!Box 7590) has the ports enabled aswell:

It’s in german, but I actually allowed all ports with the exposed host feature.

The IP-Adress changes every 24 hrs or so, doesnt it, that’s why I need an actual one, with an DNS-Service like NO-IP for example but i cant get the DUC-Client on it, that updates that IP, or can I?

For now the IP is:
88.130.62.175

I dont know if that helps but i figured out that 88.130.62.175 (or all the others that are generated) is the IP my normal PC aswell.
And with 88.130.62.175 the portcheck on https://www.ipfingerprints.com/portscan.php fails as filtered, and with its actual IP aswell (192.168.178.113).

I’ve set the IP: 192.168.178.113 in the server.properties and I’m trying to connect with the generated one (I figured it out via curl ipinfo.io/ip), or should I do it differently?

If you wonder how I’m able to figure out if it works or not by myself, I’m using GeForce NOW.

#2

Try to edit the IPv4 TCP and UDP port info, and remove the specified IP-Address under “IP-Adresse im Internet”

The 192.168.. series of IP-addresses is a LAN only IP-address , and will not work on the Internet. Port forwarding takes queries to your external IP-address and forwards them to an IP address on your LAN. It looks like ou have set up a port forwarding from your minecraft servers LAN address to your minecraft servers LAN address

#3

So, you’re saying that I need to forward the 88… IP-Adress, but that one changes every 24 hrs, doesn’t it?

#4

Usually a device do not change IP-address while it is active. So as long as you do not turn your internet modem off, it should keep its current IP-address.

Yes, you need to forward from external address (internet) to local address (LAN)

#5

Well, that’s not going to work, because this router always reconnects, u cant disable it. I’m going to try forwarding some ports from my normal PC and see if that works so that i know if its actually the routers fault

#6

I got smarter, it’s actaully the routers fault but not the way I’ve set it up because I always did it like that. I figured out though that it has something to do with the new “DS-Lite” feature that says that you dont have an public IPv4 adress if you have that enabled, so u need to rely on different kind of hosts online, but I cant disable it, of i do so, i dont have any internet connection… Perhaps you can help me figuring out how to get it working with “DS-Lite”? This is driving me crazy…

#7

One more question to be sure, with my port settings in MineOS is nothing wrong, isn’t it?

And by the way, my IPv6 is not working, if I test it with [2001:16b8:2b44:XXXXXXXXX]:25565 in Chrome, it says “refused”, even though I forwarded IPv4 and 6 mon TCP and UDP

#8

Okay, no need to deal with the DS-Lite anymore, I called my Internethoster and they’re gonna set it to a regular IPv4 connection, I’m gonna Update this post, when they have done it (In about 2 days).

1 Like
#9

So basically it’s working now, DS-Lite, is for dummies (like me) a solution for a problem noone has expected in the stoneage of the internet. We ran out of IPs, so we need a new solution, and this DS-Lite is btw called “Double-Stack Lite” and it’s kinda sorta making something with our IPv6 adresses to get rid of that “we have no IP-adresses problem” and i have no idea how to get that working with any kind of home-hosted webserver and I have no idea if it can even work…