Port Forwarding not working

I have set up a MineOS server with MineOS Turnkey and have set up my router to forward ports 25565 on both TCP and UDP. I am able to connect locally with but I am unable to connect from my public IP.

I get the error io.netty.channel.AbstractChannel$AnnotatedConnectException: Connection Refused.

Thank you in advanced for any help.

Are you connecting to https://PublicIP:25565 and getting that error. Do you have any MAC address filters applied?

I see you have pasted inn an error message. But I think we need to see more to help. Could you post the relevant log files plese?

It would also help to know some details:

  • in your minecraft client (externally): Do you see your server? Do it ping and get a green light?
  • do your clent try to connect, then fail with a connetion refused? What is the error message in your client?

It do seem like there is a block on the relevant port. There are several places such a block could reside:

  • On the server in the iptables: https://minecraft.codeemo.com/mineoswiki/index.php?title=Iptables
  • On your internet router / switch / modem: possible rror in port forwarding? Any firewalls there that blocks?
  • block at your ISP: Some of them aren’t to happy about servers and stuff running on private lines.
  • config at your ISP: minecraft / mineos isn’t to happy about IPv6, and some ISP only offer IPV6 as an external address. Check https://whatismyipaddress.com/ to see i you have IPv4, IPv6, or both.
1 Like

I just used my PublicIP:25565 without the https://, although when i tried with the https:// it just gave me an “unknown port” error. I also don’t think I have any MAC address filters although i am unsure.

I am new to this so could you please tell me which logs to post pleas?
Externally, the server doesn’t have a green light/ping.
The error message i posted was on the client-side.
also I don’t know how to configure the iptables for my specific case? Could you please help?
I tried to disable all my router firewalls but I still couldn’t get into it.
I am unsure about a block at the ISP end, but I did pay for a Static IP, does that signify anything?
I don’t have an IPv6 address as I turned it off but I am pretty sure that my isp supports IPv6.
Any help is very much appreciated!

I would start here to port forwarding your Minecraft server.

If you can connect to your server internally on the same network, then your server is working fine. You now need to show where the connection goes.

Here’s an example. If you send a letter to an address but that address is to an apartment building that has over 100 tennants. Your letter would get stopped basically at the front door because there’s no apartment number in the address. By putting an apartment number in the address, your letter will be sent to the right place.

You need to tell your router to send all traffic that’s on port 25565 to this ip, that way the server will be accessible to the outside world.

I have a router that is not on the list but I have setup a port forward for With port 25565 from the beginning forwarding to PUBLICIP port 25565.

Try this: https://www.yougetsignal.com/tools/open-ports/

Make sure that it’s your public ip in the ip text box and test to see if both port 80 and 25565 is considered open.

If both 80 and 25565 is open, there shouldn’t be any issue. Try restarting your server pc.
If 80 is open and 25565 isn’t open, you may have configured iptables incorrectly or they haven’t been applied.
If both 80 and 25565 is closed, your ISP might be restricting you and there’s nothing you can really do other then asking your ISP for help.

Oh shoot both are closed. Is that on the ISP end?

Before we both panic, let me understand how your network is set up.

Assuming your internet is coming in through a cable be it coaxial or RJ-11 to a modem, does your server connect directly to said modem or through a separate router connected to the modem?

I have a Chorus ONT (optical network terminal). which then plugs directly into my router. (A Mi Router AC2100) Then my server plugs into the router.

Ok perfect. Do you know if your dhcp is configured to work through the ONT or through your router?

Im pretty sure DHCP is handled by my router as I configured all the IP addresses through mu router.

I would consider contacting the ISP to verify that they don’t restrict the ports. There could be regulations that they need to follow as well. More in line with what iMelsom mentioned. Also, most routers should have the ability to configure port forwarding, but could be buried in the settings, or require a firmware update.

1 Like

Is your router an xiaomi brand?

@fornaxbeowulf His static ip is for the external ip not his internal one. Though you should set static ips for dedicated servers so when they restart, they don’t lose their ip. That way you don’t need to reconfigure it.

Static service may not work if the router is set for DHCP

Yes my router is xiaomi AC2100.
I have configured so that are the DHCP addresses.
and the - are static IP’s

What I’ve read from two different issues regarding port forwarding on that router is that you may need to disable upnp. That’s located under the Advanced/Additional button on the far right.

Just to confirm, that you don’t have any other device on 10.0.03.

I shouldn’t as it is the only device assigned to that IP

also uPnP was always disabled