Parts of the Web UI do not respond

After recently updating to the newest version of MineOS, the console has only worked for a little bit, after that I can only type and send commands, but these have no effect and do not show up on the console. Also the restart, stop, and various cronjob buttons so not seem to do anything. Restart of machine has no effect.

Also I accidentally submitted an incorrect cronjob time just before this, and the whole UI crashed. Updating MineOS to the latest version solved that problem, but I thought I might mention it just incase.

I know you probably want a log, but I don’t know which one to post

No, no log will be necessary. As bugs get discovered and fixed, the first thing I’ll always recommend to somebody experiencing a problem is to update their repos; that should be the first line of defense.

So I should just wait until you post here that it’s fixed? I updated literally yesterday.

I don’t understand what you’re asking. Didn’t you just say that updating MineOS solved the problem?

I just kind of assumed I knew what repo meant.
Turns out I probably don’t.
What I meant was, should I wait for you to fix the bug and post here to tell me.

EDIT: Things appear to be back to normal, all I did was leave it for a few hours. Strange.

EDIT2: I restarted a server, and the problem is back again.

Ok, first things first: have you updated MineOS?

What commit are you on (click on your name in the top-right of the webui)?

Are you running any servers that use Forge? Or any mods? It might not be Forge mods, but those seem to be the ones causing problems.

When I had problems like this, it turned out MineOS was crashing because of certain mods in my Hexxit/Forge server - namely Chocolate Quests, Battle Towers, and Zelda Sword Skills (see Ubuntu 14.04 MineOs-node wont start).

The effect was that while the server had crashed, the web pages still appeared to work until I did a refresh which then gave a server unavailable error until I restarted the server. At which point the Hexxit server would crash the MineOS instance again, after a period of a few minutes.

It sounds like hexparrot may have a handle on the cause of this (see Servers automatically restarting and nonresponsive UI which describes issues with fireworm and how some Forge mods might be updating files), at least this sounds like the problem…

Hopefully this helps if you are running any servers that use the Forge mod-loader.

Only the one server using bukkit. Around 25 plugins, the only recent one I installed was one that allowed the console to say things and have them appear in the same way as chat. I’ll try removing that and see if I have any luck.

EDIT: Had no effect.

Going through the install process, it did complete but this also came up:

npm WARN unmet dependency /usr/games/minecraft/node_modules/cron requires moment-timezone@'~0.3.0' but will load
npm WARN unmet dependency /usr/games/minecraft/node_modules/moment-timezone,
npm WARN unmet dependency which is version 0.4.1

I am now on commit 30e7dec. The problem is still there.

Can you delete the cron.config file? See if it returns to normal operation and then we can recreate the cron after that.

I deleted cron.config in the servers/ folder. Still no luck.

I tried resetting the WebUI as per this page (replacing .py with .js by trial and error), still no luck.

Just to clarify, is this an issue that is on the to-be-fixed list? Because I have to log into Minecraft at the moment every time I want to do anything.

There’s an update/reset page specifically for node.

Still unresponsive. Even the uptime counter has frozen.

What does your /var/log/mineos.log say?

If I may jump in I am having a very similar problem and my mineos.log looks almost identical to the one just posted by Dr_Glickenstine.

WebUI was working fine for a couple of days and as of last night I was unable to load the log in screen so I went to bed. This morning I have had the same problem so I updated the WebUI following the instruction on the wiki. I now successfully get the log in screen and when I log in everything works fine for up to 3 seconds. After that the WebUI is completely unresponsive other than loading pages.

I’m running a FeedTheBeast Mindcrack server using the old MCPC+ server.jar so I can run plugins.

As a side note I’ve only updated MineOS to the latest version in the last few days. The previous version was probably a year old. I had no issues with that WebUI

This is exactly same problem and details as mine, although I just run spigot with ~25 plugins.

Have you recently installed/setup an additional or new server other than vanilla minecraft?
I had the very same problem with Web-UI stalling all the time and it all started right after I had installed a new server(eg. a Paperspigot test server).

The install process and errors was:

  1. start installing a Paperspigot server
  2. setting profile, etc. (even though its not needed) and click start server
  3. server seems to start, it was marked “up”
  4. no connection, could not see it from client
  5. reloaded web-UI and noticed that the “Up time” stopped about a few seconds after login
  6. and that made the Web-UI freeze, I could enter commands, but none got through. If I tried to start/stop a server, nothing happende etc.

As the Web-UI continued to freeze a few seconds after login, I could not fix it frem Web-UI but had to do it with putty (or other linux shell) and WinSCP.

I did the following:

  1. Login via WinSCP and backup my entire minecraft folder(just in case)

  2. login as root via pytty and stop the problem server(the one I installed/setup last, that created the Web-UI freeze) using a /kill command.
    If you have the server setup to auto-restart then you might need to change that setting to “false” in the configuration or else the server will just restart when ever you kill it.

  3. Login as root with WinSCP and find server folder and delete it. Maybe you can’t delete the folder, due to file-prpoerties, but you should always be able to delete the files inside the server folder.

After that I could use the Web-UI again.

Just a suggestion, hope that helps :slight_smile:

No, this is the only server for several months now. Although, last time this did happen it turned out there was a test server I had created that had gone awry. But I changed nothing here apart from what I’ve detailed above.