Nukkit starts but does not show

I have tried a couple of times to get nukkit working. I can connect to my server on another machine. But if I create a server in mineos the server starts I chose eng in the console and the server proceeds as it should. But on my phone the broadcast is not showing and I cannot manually connect. I have also opened 19132 and even opened all ports in iptables and still no luck. What may I be missing?

Tells me the server is up and running, good.

Phones would be on another network, so this is a good test of whether or not the port is open and forwarded.

If you can connect to the server on another machine, it already tells us that IPtables is open enough to allow connectivity in. I it’s the case you’ve opened all ports in IPtables, that should suffice, but you should also lock it down, later too.

The port forwarding. This means going to the router and signifying that if there are any inbound connections from the internet (your phone, in this case), identify traffic coming in on port xxxxx (19132, in your case) and forward it to server IP 192.168.x.x (the IP of your MineOS machine).

Normal networks don’t need forwarding because your client is already on 192.168, which is the same as the server. But your phone isn’t, and can’t be on the same network. So port forwarding allows all traffic from off-network to get sent to the right machine, in-network.

If by this you mean you already port-forwarded, then I think it means you simply need to return to these settings and re-confirm their validity. One other option is that the port is blocked at your ISP-level (who you pay for internet). This is less common, but not impossible an explanation.

Sorry meant to say I have a nukkit server on another machine I can connect to not connect to this one on another machine. I manually installed nukkit on a separate vm.

All of this is local on the same network. Phone and server.

It is really unclear what your setup is.

It could be the networking to your VM, which would mean you have to look at the connectivity of your hostmachine (the machine that runs your VM).

I’m not sure I know how to further troubleshoot without having at least a little better idea of what you’re trying to do, and how you’re attempting to set it up.

vm1 has ubuntu 16.04 with nukkit running and nothing else. Can connect and see broadcast in iphone mcpe game. All on same network. This was a test to see if i could even connect to a nukkit server.

vm2 has mineos with 2 minecraft servers and a nukkit server. Minecraft works great on 2 separate ports. Nukkit starts fine by console but never see broadcast and cannot connect if i manually put in ip and port. All local again. Have ports open in iptables. Have entered in eng when it asks.

Sorry if this is confusing.

@hexparrot Did my last post help any?

When and where did you do this?

When I created a nukkit instance, it never asked me from the webui. I actually ended up connecting to the screen instance manually, only to find out why you were saying you were typing in eng, at all.

Then, after typing in eng and hitting enter, I saw that it opened the server on and it started working. Since I don’t have a mobile client though, I have no idea if the broadcast was working, but 100% the server was listening, as confirmed by netstat -ntlp from the mineos host console.

But I’m curious when and where you knew to type in eng, based on your description in vm2.

I entered eng in the log window in the webui.

Is that even possible? Does nukkit make a server.log file that is trackable? It didn’t for me, anyway.

What does the log say then? Does it confirm that the server has started?

Says is working correctly. But I cannot connect on phone or win10.


Sounds like a firewall issue. You’re running it on 25568, which is fine but:

It’s good you know to address this, though in troubleshooting steps like this, understand we need more verification than simply saying so. There’s a lot of components, and it’s often easy to overlook small things.

Can you provide the output of your firewall?

Beyond that, also verify you’re typing in 25568 in your client, because it’s not default.

I will have to wait til tonight to get screenshots from my phone when I’m in the network.

Iptables list

Mcpe server settings

This is what netstat -ntlp shows.netstat. Looks like 25568 is not there.

Ok finally got this working.
I ran these 2 again.

iptables -P INPUT ACCEPT
iptables -F

Tested was not able to connect with this error in console.
at cn.nukkit.Player.handleDataPacket(
at cn.nukkit.raknet.server.ServerHandler.handlePacket(
at cn.nukkit.Server.tick(
at cn.nukkit.Server.tickProcessor(
at cn.nukkit.Server.start(
at cn.nukkit.Server.(
at cn.nukkit.Nukkit.main(
2020-2-29 16:18:20 [INFO] [/] logged out due to client disconnect

Checked on nukkit forum and was told to try a newer version of the jar file. So replaced the jar file for my world and tried to connect. Success. Except I was under the world and falling. So delete of that world and create a new world and finally success. I’m able to connect and play nukkit on mineos on my phone.

Thanks for the help with troubleshooting. @hexparrot

1 Like