Noob trying to Create an RLCraft server

Hey all I’m very new and VERY green with this type of community. I’ve successfully made a vanilla server after many many tries and a friend of mine would like to play a RLCraft server together so that is my next project. I am wondering if anyone has any Noob friendly advice on how to get started with this. I’ve tried to find this topic on the forum but only found RLCraft mentioned a little in some of the comments. I am willing to learn and to put in the effort. I just don’t know a good starting point for a FreeNas user would be.
I’ve started to read up on your Linux starter guides and have watched a few how to videos with putty and filezilla
So far I have forge 1.12.2 installer uploaded and am kinda wondering where I go from here with mod importing

I haven’t done a lot of modding, but what I’ve learned, is that mods should reside in the server’s …/datapack directory.

so… heres an update i created an RLCraft server on my desktop and tried to dump the files into my mineos /var/games/servers/ file and it broke my plugin it think it was because it had a start.bat file in it

the server i created was based on this video

The way I did my RL Server is very similar to the video.

  1. DL the server pack and make sure it loads/starts on your computer no issues.

  2. In the WebUI, make a new server and just give it a name. Don’t bother changing anything else.

  3. In FileZilla, go to your directory to where your Minecraft servers are located. (Etc. /var/games/minecraft/servers/nameofserver
    then copy the contents of the RL Server from where you first launched it to that directory.
    You may need to refresh the WebUI after its finished copying over.

  4. Once the WebUI has refreshed, go to your RL Craft server and choose both the profile to Forge 1.12.2 and choose the runnable jar file to the one that was created.

Set your RAM amount to 8192 and 2048 (though if you can I personally set it to 10240 and 10240) respectively and set your JVM Args to this:
-XX:+UseG1GC -XX:+ParallelRefProcEnabled -XX:MaxGCPauseMillis=200 -XX:+UnlockExperimentalVMOptions -XX:+DisableExplicitGC -XX:+AlwaysPreTouch -XX:G1NewSizePercent=30 -XX:G1MaxNewSizePercent=40 -XX:G1HeapRegionSize=8M -XX:G1ReservePercent=20 -XX:G1HeapWastePercent=5 -XX:G1MixedGCCountTarget=4 -XX:InitiatingHeapOccupancyPercent=15 -XX:G1MixedGCLiveThresholdPercent=90 -XX:G1RSetUpdatingPauseTimePercent=5 -XX:SurvivorRatio=32 -XX:+PerfDisableSharedMem -XX:MaxTenuringThreshold=1 -Xloggc:gc.log -verbose:gc -XX:+PrintGCDetails -XX:+PrintGCDateStamps -XX:+PrintGCTimeStamps -XX:+UseGCLogFileRotation -XX:NumberOfGCLogFiles=5 -XX:GCLogFileSize=1M -Dusing.aikars.flags=https://mcflags.emc.gs -Daikars.new.flags=true

finally add nogui to the second text box.

If all well and good, it should start up no issue.

would u have a tutorial on this like a video?