Non-PAE support for Turnkey MineOS


Hopefully not too much of a newbie question… I just inherited an old Motion Computing M1400 tablet PC that I wanted to use to host MineOS (small, built-in screen, low power usage, etc). The only problem is that when I try to install MineOS Turnkey, I get an error saying that my hardware does not support PEA and I need to choose an appropriate kernel for my hardware. So, I am hoping there is a way around this? Is there a way to force MineOS Turnkey to not use the PEA functionality? Or, is the HW just too old for this image? If not, is there an image I can install and then layer MineOS over?

Thanks in advance for any support!


1 Like

MineOS can be installed on pretty much any Linux you can get Python and Java on.

Are you able to get any other distros on your machine?

Thanks for the response! I really appreciate the help…

I haven’t tried any other distros yet… was waiting to see if I had any hope to use Turnkey (not much experience as a Linux admin, so was hoping for the easy solution! :smile: )

Given the age of the HW (it is a 1.1 GHZ centrino processor with 2 GB of RAM, no PAE support), I am hoping to get as light an installation as possible (e.g., I don’t think I even need a desktop manager). Do you have any suggestions on which one to use? Also, once I have a distribution loaded, what are the next steps (do I have to load Python and Java manually? Or, will your scripts automatically do that?).

Thanks again for any support on this… my kids will thank you forever!!!


Your hardware (and its lack of PAE support) is likely going to decide for you what distro you can use, but I suspect pretty much any distro will do.

MineOS largely refers to “the webui” portion–the webpage you use to create and administer your servers, but MineOS also refers to the collection of documents/guides that help you get ready for installing the web-ui as well.

See the MineOS wiki which will give you full instructions from taking the most popular distributions and making them your Minecraft server platform. If you find you’re using (or choose to use) a distro that isn’t listed there, let me know, and I’m sure the instructions can be adapted appropriately.

1 Like

Doing some more googling, it looks like my processor (an older version of Pentium M) does support PAE but the processor doesn’t flag it. There appears to be a way to install Lubuntu on it, forcing the flag. So, I will try that when I get home tonight.

Once/if I get Lubuntu installed, I am still not sure on the next steps (forgive my Linux ignorance!). I am not sure how to execute the installer script for the MineOS webUI. Couple more questions: 1) the installer scripts will set up the server and UI to automatically start up, correct? 2) Do I need to run the desktop manager or is that something I can somehow disable (and free up those resources)?

I will let you know how it goes… again, thanks for everything!


1 Like

You do not need a desktop or window manager at all. MineOS requires none of that and can be installed on server distros and pretty much any distro. You could probably get an older (or even a newer) version of an ubuntu server that would work for you.

Interested to see how this turns out @gbenderly, Let us know what happens with Lubuntu!

Also, I did some looking around and found that Linux Mint Debian supports non-pae cpus. See under multi-core cpu section here:

Download here:

See this thread to boot directly to terminal in Linux mint if you don’t want GUI:

@gbenderly also, it seems that these releases of Ubuntu are all based off of the Debian Squeeze kernel(6.x) which has non-pae support.

11.04 natty squeeze / sid (Download:
10.10 maverick squeeze / sid (Download:
10.04 lucid squeeze / sid (Download:

If you want to give either of those releases a shot I’m sure you can get them running on your tablet. From there you can manually install the rest of the MineOS components using the wikis that @hexparrot outlined.


Thanks for the help! I actually found something on the Ubuntu website that I will try this weekend –

In theory, it should give me an Ubuntu 14.04 ISO that will load without PAE support. I will let you know how it loads.
(as an aside, in doing some reading of Mint vs Lubuntu, the consensus seemed to be that Lubuntu is preferred if looking for minimal footprint)

But, showing my Linux naivete, I need some help on how to install the rest of the MineOS components. The Wiki says “Using an existing setup, execute the convenience installer script via gist (wget-friendly link)”. But, I am unsure on how to do that? I assume it is a simple one-line command, but I am just missing the syntax…

Again thanks everyone for the help!! I will report progress updates…


Once installed open terminal if you have a desktop or just type into the command line
Wget url-goes-here
Then you type
Sudo ./

actually, wget url-goes-here | sh may be easier.

Ordinarily this works quite well, but it actually on this script you’ll want to do them in separate steps because the apt-get update install fudges with the execution and the remainder steps get lost in the updating.

Well, after great effort, I finally got an image to intall on the computer – Ubuntu Server 10.04. This was quite a task trying to find a distribution that would work!

My issue now is that openjre 7 is not available from the repository for this version of ubuntu. So, I am not sure what to do: (1) can I use openre 6 with mineOS (I tried running the script, but I don’t think it was successful…) (2) or, how can install openre 7 without using apt-get?

Again, any advice is greatly appreciated!

MineOS doesn’t actually use Java, it’s Minecraft that does. So any version of Java will do–provided that Minecraft itself will run on that version.

That said, while your 10.04 version may immediately support jre 6, it isn’t likely going to prohibit you in any way from using the modern 7, but you may have to build it manually, or add a new repo to download one configured properly for such an old release.

Also, oracle Java never comes with distributions anymore (compared to open jre, which is fully open) so most online guides can explain getting Java working without changing repo configurations for apt-get and just downloading compressed archived with it pre built.

Let us know what route sounds right to you.

Personally I like using Oracle Java through PPA or in other words using an additional repo with apt-get.
If you want to go that way this page may help.

1 Like

Wanted to give an update on this:

  • I finally got Ubuntu on the tablet… had to go back to 10.04 (took me about 10 different distributions to find this one that worked and some wacky installation steps, but it went eventually!) and then do an upgrade to 12.04
  • MineOS installation scripts went perfectly and servers are up and running
  • I was also able to get the PocketMine server up and running (thanks for the instructions on that as well!)
  • Performance seems OK so far (about 700MB -900MB of RAM used for the OS, PocketMine, and a Pixelmon server); still need to load test more users to see when it maxs out
  • Last issue is that I can’t seem to get Ubuntu to recognize the wireless card (built into the Centrino processor); I know the wireless works as I can see my router, just can’t get it to register with it.

Again, thanks to everyone for the help with this!


I know you’d have to use wpa-supplicant, I believe that was already included even in 10.04 but might be worth checking.

Hey, late to the party here but I see you managed to install Pixelmon. I’ve been unable to figure out how to do that, do you happen to remember how that was done?