No server will start from CLI or webUI (1.19)


Web UI git commit: 448f367

Minecraft server version (1.19)

OS: Rocky Linux 8.6 (Green Obsidian) x86_64
Kernel: 4.18.0-372.9.1.el8.x86_64
Memory: 564MiB / 15824MiB
VM running in NodeNext (RHV Hypervisor)

root@minecraft01 log # java -version
java version "16.0.1" 2021-04-20
Java(TM) SE Runtime Environment (build 16.0.1+9-24)
Java HotSpot(TM) 64-Bit Server VM (build 16.0.1+9-24, mixed mode, sharing)

Firewalld configured to allow: 25565/tcp 25566/tcp 25567/tcp 25568/tcp (also fails with firewalld stopped)


CLI command:

root@minecraft01 log # /usr/games/minecraft/mineos_console.js -s Archapelego start && sleep 5 && /usr/games/minecraft/mineos_console.js -s Archapelego up
[Archapelego] Successfully executed "start"
[Archapelego] Queried property: "up"

I can’t start any server from either the CLI or webUI - I even created a new server to test and nothing. I also don’t get anything in the logs about it:

root@minecraft01 log # tail -f mineos.log
{"level":"info","message":"[Archapelego] issued command : \"start\"","timestamp":"2022-06-10T03:42:46.575Z"}
{"level":"info","message":"[Archapelego] received request \"start\"","timestamp":"2022-06-10T03:42:46.576Z"}

<nothing after this...>

This worked two weeks ago without any issue (1.18.2), but won’t work on that version now either.

Expected Behavior

server should start

Actual Behavior

Not even a peep from the logs, and nothing starts

Very Repeatable

You’ll need to update your Java I think.

Thanks for the reply. Which version should I be on?


per @ElPres comment to check java, I went through my dnf logs (update logs for Linux) and found that I was on java 17 before I updated a few days ago. As you can see from my original post, I was running 16 after the update :frowning: – so, I simply configured my system to use 17 again and it worked:

root@minecraft01 log # alternatives --config java

There are 4 programs which provide 'java'.

  Selection    Command
*+ 1           /usr/java/jdk-16.0.1/bin/java
   2           java-17-openjdk.x86_64 (/usr/lib/jvm/java-17-openjdk-
   3           java-11-openjdk.x86_64 (/usr/lib/jvm/java-11-openjdk-
   4           java-1.8.0-openjdk.x86_64 (/usr/lib/jvm/java-1.8.0-openjdk-

Enter to keep the current selection[+], or type selection number: 2

Check … Done

I have the same issue, only I’m using Java-17.0.1

root@MineOS /# java -version
java version “17.0.1” 2021-10-19 LTS
Java™ SE Runtime Environment (build 17.0.1+12-LTS-39)
Java HotSpot™ 64-Bit Server VM (build 17.0.1+12-LTS-39, mixed mode, sharing)

For what it’s worth. I used the profile tab to download the 1.19 version and it looked like it didn’t download the entire .jar file. Every time I tried downloading and copying profile to server it moved the 1.19.jar with a size of 0KB.

I used WinSCP to look at file names and sizes. After eventually downloading it a couple times, I finally got a working version of the 1.19 profile.

You can also use ls -al to list out file names and sizes.

root@MineOS .../servers/Giganto# ls -al
total 45560
drwxrwxr-x  6 mc   mc       4096 Jun  8 13:30 .
drwxrwxr-x  4 root root     4096 Jun  5 19:28 ..
drwxrwxr-x 12 mc   mc       4096 Jun  8 14:22 Amped My Guy
-rw-rw-r--  1 mc   mc          2 Jun  8 14:19 banned-ips.json
-rw-rw-r--  1 mc   mc          2 Jun  8 14:19 banned-players.json
-rw-rw-r--  1 mc   mc          0 Jun  5 19:28 cron.config
-rw-rw-r--  1 mc   mc          9 Jun  5 19:30 eula.txt
drwxrwxr-x  8 mc   mc       4096 Jun  5 19:34 libraries
drwxrwxr-x  2 mc   mc       4096 Jun  8 14:19 logs
-rw-rw-r--  1 mc   mc   46592587 Jun  5 18:40 minecraft_server.1.18.2.jar
-rw-rw-r--  1 mc   mc          0 Jun  8 13:30 minecraft_server.1.19.jar
-rw-rw-r--  1 mc   mc        266 Jun  8 14:19 ops.json
-rw-rw-r--  1 mc   mc        155 Jun 11 02:25 server.config
-rw-rw-r--  1 mc   mc       1211 Jun  8 14:19
-rw-rw-r--  1 mc   mc        209 Jun  8 14:19 usercache.json
drwxrwxr-x  3 mc   mc       4096 Jun  5 19:34 versions
-rw-rw-r--  1 mc   mc          2 Jun  5 19:34 whitelist.json
root@MineOS .../servers/Giganto#

It’s working for me now.

I am not sure if I’ve got the same problem here… I’ve got java v17.0.3 installed on my TrueNAS MineOS installation, but the server, when set to 1.19, does not start.