"No Profiles Available" reported in webui, but internet is OK

Due to a recent break in a URL in a profile, many are experiencing errors where profiles are becoming entirely unavailable.

I have resolved this with a recent commit, which allows the webui to gracefully handle broken URLs.

Updating the webui as normal should resolve this, with no further action. Broken URLs will simply be ignored (and not break profiles), yet still be logged as broken.

cd /usr/games/minecraft
git fetch
git pull
[restart webui]


Been looking into getting this issue fixed on my Freenas Server 11.2-u5, but having a hard time trying to find where to input the “cd /usr/games/minecraft”, I tried putting it in the mineos jail shell as well as the main Freenas shell and neither of those worked. then went into mineos management and the servers shell and that didn’t work either. Kinda at a loss and would appreciate some help. Thanks

I don’t maintain the FreeNAS plugin of MineOS, I only maintain the webui program itself (for general use).

That said, I think in the BSD systems, the path is changed to /usr/local/games/minecraft

It all seemed to work until I got to “git pull” where it gave the following error:

root@mineos:/usr/local/games/minecraft # git pull
Updating b28c5be…9cf8fe1
error: Your local changes to the following files would be overwritten by merge:
Please commit your changes or stash them before you merge.

how do I commit the changes so the update can be completed?

git fetch --all
git reset --hard origin/master
This overwrites any changes you made so use it carefully.