No one outside my network can join the server

For the past couple of days I’ve been troubleshooting everything. I’ve check the port and its listed as filtered (rejecting incoming). I’ve checked iptables and all 3 show up as (policy ACCEPT). some weird things that have happen are every time I restart the system I need to reconfigure the network and when I checked for my ip on the system using ss -tulpn it showed as *:25565 in the list. I’m not sure what network card I have and I don’t know how I check that on MineOS.

I’m very new to Linux in general so if you need more info don’t be afraid to ask.

P.S. I do know my public ip and I can run a server on my personal desktop and a server will run no problem allowing friends to join outside my network.

To let people connect from outside your network you need to do setup “port forwarding” on your router. It will look a little something like this:
LAN IP of server =
Port forward will let people connect to your WAN IP and your router will forward that traffic on to in your internal network.

The exact menu and phrasing will vary from vendor to vendor.

Use the command ‘ifconfig’ to show what network adapters and addresses are assigned.

i have port forwarded and reforwarded incase i missed something. I’ve given friends outside of my network the external ip and they cant connect. I can connect internally. ive also tried making a server on my personal rig and that will allow other outside my network to connect then. it just wont work on the dedicated server im trying to use.

ive done that and it only show the internal ip. i know my external ip (assuming other forums are right and i only have 1 external ip) and have given that to friends to try and connect.

What distro are you using?

If you’re doing network config manually, often you have to update the network init script to have it configure on boot. I usually use dhcp and set a static lease in my router, just easier for me.
Then you need to setup iptables (if using iptables) and that needs to be saved and loaded each boot also.

If you’ve port forwarded correctly and done the networking and firewall config it should all work.

Using MineOS customised TKL distro eases this setup, if you’re running on bare metal then these steps should work. If you’re running as a VM on some machine then you need to do a bit more.

Im using the mineos turnkey that available right on the main page. I do use DHCP when i reboot and it connects also instantly. Ive tried re-porting twice on the dedicated server and a third time to test on my gaming rig.

It worked on my gaming rig just fine. Ill try again when i get home from work to see if iptables lists and different external IP then my gaming rig but other than that everything is correct on how you described in your comment.

Also its a bare metal rig not a VM

The external IP should not be mentioned on the server at all.

Ensure either or your internal (adapter) ip is in the server properties.
Post your latest.log, mineos.log and

sorry it took me so long to get back to you but i finally got some time off work so i can sit down and focus this week.

when checking the mineos log i kept getting this {“level”:“error”,“message”:“Ping, MC Server not available on port 25565”,“timestamp”:“2022-12-05T16:22:23.293Z”}

im assuming that this is my issue but i know its ported correct and i use my own router. my isp only provided the modem.

Edit: i figured it out. Everything was ported correctly but i didnt know my router had an optimization protocol that auto generates when it detects a game port. I have a asus gaming router. I managed to find the section that was buried 3 menus and change that local ip to my MineOS server. For some reason even though it was all ported correctly the optimizer went around my port and was looking for my gaming pc which is why the port worked instantly when testing on it.

Thank you for all your help!

1 Like