No connection whatsoever


I’m completly new to this distro and I don’t know ANYTHING about it. I’m runing mineos turnkey on a old laptop, and I don’t have a ethernet port, so I tried to connect via wifi, but everything I try fails miserably. The wiki page method doesn’t do shit and I don’t know what to do. Thanks

Old laptops without ethernet aren’t really ideal. Server distributions aren’t designed to be run on wireless environments, for example, so getting wireless up and running on the MineOS Turnkey ISO is probably more trouble than it’s worth.

You say you are completely new to this distro–are you experienced in any other distributions? If so, I recommend you get wireless working on any distro of your choice, which you can follow up with instructions from the standalone web-ui wiki page, which will help you get the web-ui set up.

If you are not familiar with other distros (as in, this is your first), I recommend you stick with MineOS Turnkey, but instead just use a different machine that doesn’t require wireless setup or have MineOS Turnkey running in a Virtual Machine.

The thing is, I can only run it on this laptop and I just want to know how do I connect it via wifi.

I understand that you “just” want to know how to do something, but I’m telling you that what you’re trying to do is not what the distribution was designed to do. That is not to say that it cannot be done (because it can), but it will require more involvement than asking for some simple copy/paste-able instructions that will get it up and running.

What have you tried?

It would also help if you could answer questions that would give me and others a better feel for how technical we must be to help you out–not to mention get the sense that our responses are read and heeded.

I tried auto DHCP connect in the configuration console, but it doesn’t detect anything, then I looked at the wiki page, but when I try it it just says “-bash: wpa_passphrase: command not found”

The other linux based systems I’ve used are zorin 9, Ubuntu and Mint, always with visual interface.

While the wikipage provides some instruction on getting Wireless working, I recommend finding more polished tutorials online which do a better job (mineos wiki = just me, internet tutorials = much more review).

When you get an error, typically the error will demonstrate exactly what needs to do next. In your case of providing this:

It tells me your installation (as expected) does not have the wireless utilities (that server distributions typically don’t have).

You can download them with:

apt-get install wireless-tools
apt-get install wpasupplicant

But again, I recommend since MineOS Turnkey is a Debian-based distro that you seek out and use any other Debian-based tutorial out there for setting up wireless on DHCP–they all will work, even most (if not all) Ubuntu tutorials.

“Unable to locate package wireless-tools” Everything ends up to something like this.

Probably need to update your repo cache then, as you would in Ubuntu:

apt-get update

Apt-get doesn’t do anyhthing either, it ends up to “failed to fetch (url)”

They’re not connected to the Internet. They mentioned that in the first post.
You’ll need to either download a package on another computer and transfer it over or just install ubuntu on the laptop and install mine-OS on top.
The steps you need to take (find the relevant commands by googling)
Find out if your wireless card is detected by the distro - lspci or even ifconfig
See if the distro comes with wpa-supplicant - wpa-supplicant
Configure wpa-supplicant to connect to your wifi.
Once connected you can do the sudo apt-get update and proceed to use apt-get commands etc

Oooh, thats

Definitely right. Glossed over that. Yes, the answer, however, is definitely to start with a distro that can get your wireless up and running on its own–without any of the inconveniences of moving files to a computer who has no internet connection to start.

If you find any distro that can get your wireless running out-of-box, I’m sure we can go through the very few steps together to get MineOS atop that distro.

Cheap and semi effective solution usb to ethernet so you can plug into cat5 cable and go wired instead.