No connection to friend's server

For some reason, 5 other people have been able to connect to his server except for myself. I can connect to other servers with the exact same version. I have made sure I have the same version that they use. We’re very confused and can’t find anything on youtube or google to help with this issue.

so you can see the server and that there are people logged on in your list?
What error are you getting?

I had an issue similar to this… I’ll post the link to the thread here, in case should it be of any help to you.

ElPres is right though… the community needs more details if you want some help.

I’m not the one who is hosting the server. I’m trying to join a friend’s server who uses Mine OS. Everyone else can join with no problems. When I put in the IP in the Minecraft Menu, it shows me that the server isn’t up(its red with no bars). When I try to click on it to join, it just tells me that I failed to connect and has no error code. Yet I can join other servers with the exact same minecraft version and exact same modpack version.

Dude, I’m not trying to host a server, my original post is as clear as I can possibly get.

well, MineOS isn’t your problem. Can you ping the IP? Double checked that the IP is correct? Double check which port he is running it on.

I can ping the ip, the port is correct, ive double checked the ip each time we’ve tried different things. How can you say for 100% fact that its not Mine os? I’m pretty certain its Mine os since I can connect to every server besides his. Also, we tried to connect to his server while he was hosting a vanilla world and still the same issue, so its definitely not the mod pack.

So 5 out of 6 people can successfully connect with no issue, but since one cannot, it is likely MineOS?

I can assure you there’s no “block the 6th user” setting, nor could a web management script/interface even successfully pull that off.

You’re providing insufficient information about how others are connecting–are they all LAN and you’re external to that network?

If there are other external-users like yourself, then it’s even less likely MineOS because it’s demonstrating successful connectivity already.

Is it operating on a port that’s not 25565? Perhaps you have been omitting that from your client.

Put short, provide more detail to your issue and try to provide any evidence that a background Python script is preventing your connectivity. It is of little help to say you’re doing everything right, rather than specifying WHAT you’re actually doing, because we can’t diagnose with “it just doesn’t work”

Best guess: all other users are in-network, you’re external. You’re able to pong, because the router is responding but cannot connect because the routers port forwarding is unset/incorrect.

no, they’re all just like me, external. The port is 25565. I’m not the one whos hosting the server, its my friend whos hosting off a separate computer. All i’m doing is taking their IP address and adding it to my server lists in the menu. Then I see it in the menu and it says that it has no connection before I even try clicking on it. Originally when I was asked if it was pinging, I thought I had to use a program to see if it could ping and it did but now I see that they were asking if it had a ping in the menu and it doesn’t. Here is a picture. It’s “Gates” server.

here is the error I get when clicking on it to join:

Googling that exact error seems to present hundreds of similar cases , none of which seem to think the OS or the server management system is at fault.

The vast majority are pinning it as being client-specific, whether it is firewall or Java version. In some cases, there have been recommendations to merely restart the minecraft server (the Java jar itself) as it could be failing on that end.

I’d be suspicious of your local firewall the Least and mostly of the server jar, but that said, the firewall isn’t impossible, I just am personally unsure how to further address it, as I’m presuming you have a relatively simple firewall, e.g., windows firewall. Thus, minecraft server restart… might resolve an otherwise unexplainable and unavoidable hiccup. This is the best first step, I think.

Who knows, perhaps that Java error is coming up specific to your user…unlikely as it seems from the outset, it might shed some light in the logs. Do you have access to ask for those?

It isn’t clear, but I think even a local client reboot would be of value. Typically errors like to be useful… This error has it baked in “no further information” which sorely leaves us with little to go on.