New to MineOS - Need help getting set up

Hey there,

I’ve been running a small modded Fabric/Geyser server for my family and a few friends off of my PC for a month or so now. I just bought a cheap little rig and set up my first MineOS server to run it off of so I could keep it on 24/7 (mainly due to time difference between most of my friends and I), but I’m quite unfamiliar with Linux or MineOS in general. I’m sure I’ve made several mistakes along the way with the setup or migration that cause some of the issues I’ll discuss below.

My friend is somewhat versed in Linux or at least seems to know his way around it more than me, anyway, however, we can’t seem to put our brains together to get this server working the way we’d like. We are trying to migrate my Fabric 1.20.1 server from my PC to the MineOS rig, which I’ve been doing using mRemoteNG as well as FileZilla. I have followed a guide from another post on here on how to get Fabric set up on MineOS. I apologize for the long back story.

What I’ve done so far is:

  1. Create a fresh Fabric server and test run it.
  2. Import the following files from my server: config, mods, world,, whitelist
  3. Server seems to function for me locally.
  4. I tried port forwarding the MineOS PC, but I’ve had no luck so far (ill explain in better detail below)

Here’s my issues:
Issue #1. I can start the server on the MineOS WebUI and it starts fine so far every time, however, I can’t stop it. Every time I hit stop I get a [server] stop failed. I successfully managed to shut it off a few times by going into the Logging and treating the log window as I would on Windows by typing “stop” in the console. That did the trick one or two times on the fresh Fabric install, but I haven’t been able to do it since I imported the files from Step 2.

Issue/Query #2. I’m sure importing some of these mods or not having certain dependencies is incompatible with Linux in some what. I’d love to get some knowledge or input about how to do it correctly and what I can and cannot import.

Issue #3. My internet provider is Xfinity (comcast). I’ve heard they’re not the best, but they work for where we live currently. I have successfully and somewhat effortlessly port forwarded my PC to open the ports I need (19132 (geyser), 19133 (geyser), 25565 (mc), 8123 (dynmap)) as well as set up a no-ip link to act as the external IP my friends could connect to the server with. I tried port forwarding my MineOS PC the same way I did my PC, but the first time I did the MineOS ip changed from .27 to .28. Ever since, it has been ping-ponging back and forward when I restart the machine. The port forwarding worked well on my PC but I can’t seem to get this replicated on MineOS, and I’d love some input here as well on how to accomplish this. I’ve seen forum posts on iptables and things like this, however, I’ve had no luck accomplishing this on my own.


  1. I’d like to transfer my existing modded Fabric 1.20.1 server from my windows PC to my MineOS dedicated server pc.

  2. I need some help port forwarding so that Geyser works for mobile users and that others can join in general.

  3. I’d like to understand and learn what I’m doing wrong in terms of compatibility and set up so that I can improve my understanding in how this all works and become a little bit more familiar with the Linux/MineOS in order to run this server efficiently for my friends and family.

I apologize for this lengthy flood of information, I’m sure a lot of it is just me talking in circles getting all this weekend long frustration out of me! I appreciate any and all help in advance.