New to Minecraft - mod question
Is it possible to easily get this running on a MineOs without a ton of work? :slight_smile: Or does anyone know of a similar mod that will work with an existing server type on MineOS? I’m not afraid of the linux command line, just not super familiar with Minecraft (this is for my son and daughter).

Haven’t tested what I’m about to say, myself, but I see no reason why it would not work.

Per this page, you’ll be following the CLI installation steps.

  1. Create a brand new server in the webui, giving it a name and not starting the server–we’re simply getting the filestructure in place for us to put fabric into.

  2. You’ll log into your MineOS host, as a non-root user (e.g., mc or whatever name you choose). This is the black&white console (or putty, or terminal).

  3. navigate to your server directory. It is on the page where you created the it in the webui, which follows the format /var/games/minecraft/servers/]

cd /var/games/minecraft/servers/[myserverijustcreated]

  1. You’ll download the file with something like:


  1. Again, ensure you are NOT root. Run the fabric-installer:

java -jar fabric-installer- server -downloadMinecraft

This should download Minecraft’s server jar from Mojang

  1. It’s my understanding you’ll be left with fabric-server-launch.jar downloaded, and perhaps minecraft_server.jar. The latter would be a parameter passed to the former, for example:

java -jar fabric-server-launch.jar minecraft_server.jar

If this starts the server, then I believe the server-side is done.

Extra emphasis that all this was written without having attempted the install at all; it’s not something I’m able to do at this exact moment, but intuitively, these steps feel like the correct adaptation of the instructions given.

If anybody else here has worked with fabric, I hope you can chime in about other steps required, or whether there are alterations needing to be made here.

I’m not familiar with Fabric, and seeing how there’s a “fabric client”, this is generally a server-client model I do not work much with (I usually only work with servers that support the official Mojang client).

With all that said, so long as the client step is separate and unattached from the server, then if the server comes up, then in the webui, you would then add fabric-server-launch.jar as the “runnable jar” in the webui, with “minecraft_server.jar” (or whatever file is downloaded from step 5) would be the additional jar arguments.

Let me know if this helps make any progress, and we can try troubleshooting to make progress on each step.

Thanks - going to mess with it now.

I did the step five with the -download flag and that worked.

step 6 should be vi/nano/pico (VI IS BETTER :grinning: ) the eula.txt and change false to true

After messing with it for a bit, I can’t seem to get the gui to control start/stop of the server. I am able to select the fabric-installer.jar in the java settings, but clicking start/accept eula/start doesn’t do anything. I can launch it from my ssh window using the “java -jar fabric-server-launch.jar minecraft_server.jar”

Viewing the server status in the gui does add a “Player Interaction” menu item on the left. doesn’t seem to work though. Tried to /tel USERNAME test and it say “server must be up”.

This probably shouldn’t be necessary at all. Fabric installer should only happen once, and presumably all of those should be done in step 5.

Beyond that, if you’re able to launch it successfully via SSH, then you probably can get it working from the gui, but it’ll likely use fabric-server-launch.jar. Also, it’s a launcher jar…which is … a little more delicate. I’m curious as to whether it likes or dislikes any of the arguments passed to it, such as the memory, etc. since it’s really only a intermediary. Let me know if you make more progress or if there’s a concrete place it is always stopping ya.

Server def runs and my son and his friend were able to connect to it. Here are the launch log entries:
mc@mineos-tkldev …/servers/OriginsWorld$ java -jar fabric-server-launch.jar minecraft_server.jar
[00:13:30] [main/INFO]: Loading for game Minecraft 1.16.5
[00:13:31] [main/INFO]: [FabricLoader] Loading 3 mods: minecraft@1.16.5, java@8, fabricloader@0.11.1
[00:13:31] [main/INFO]: SpongePowered MIXIN Subsystem Version=0.8.2 Source=file:/var/games/minecraft/servers/OriginsWorld/fabric-server-launch.jar Service=Knot/Fabric Env=SERVER
[00:13:37] [main/INFO]: Environment: authHost=‘’, accountsHost=‘’, sessionHost=‘’, servicesHost=‘’, name=‘PROD’
[00:13:38] [main/WARN]: Ambiguity between arguments [teleport, destination] and [teleport, targets] with inputs: [Player, 0123, @e, dd12be42-52a9-4a91-a8a1-11c01849e498]
[00:13:38] [main/WARN]: Ambiguity between arguments [teleport, location] and [teleport, destination] with inputs: [0.1 -0.5 .9, 0 0 0]
[00:13:38] [main/WARN]: Ambiguity between arguments [teleport, location] and [teleport, targets] with inputs: [0.1 -0.5 .9, 0 0 0]
[00:13:38] [main/WARN]: Ambiguity between arguments [teleport, targets] and [teleport, destination] with inputs: [Player, 0123, dd12be42-52a9-4a91-a8a1-11c01849e498]
[00:13:38] [main/WARN]: Ambiguity between arguments [teleport, targets, location] and [teleport, targets, destination] with inputs: [0.1 -0.5 .9, 0 0 0]
[00:13:38] [main/INFO]: Reloading ResourceManager: Default
[00:13:39] [Worker-Main-4/INFO]: Loaded 7 recipes
[00:13:39] [Worker-Main-4/INFO]: Loaded 927 advancements
[00:13:41] [Server thread/INFO]: Starting minecraft server version 1.16.5
[00:13:41] [Server thread/INFO]: Loading properties
[00:13:41] [Server thread/INFO]: Default game type: SURVIVAL
[00:13:41] [Server thread/INFO]: Generating keypair
[00:13:41] [Server thread/INFO]: Starting Minecraft server on
[00:13:41] [Server thread/INFO]: Using epoll channel type
[00:13:41] [Server thread/INFO]: Preparing level “world”
[00:13:42] [Server thread/INFO]: Preparing start region for dimension minecraft:overworld

[00:13:51] [Server thread/INFO]: Time elapsed: 9156 ms
[00:13:51] [Server thread/INFO]: Done (9.292s)! For help, type “help”
[00:13:51] [Server thread/INFO]: Starting GS4 status listener
[00:13:51] [Server thread/INFO]: Thread Query Listener started
[00:13:51] [Query Listener #1/INFO]: Query running on

He was able to connect to it using regular Minecraft client/game. Still reading up on the Fabric client for his computer.

Interesting! If it runs like that from the CLI, it should absolutely run from the webui too. No luck there?